HDU 1026 Ignatius and the Princess I (基本算法-BFS)

Ignatius and the Princess I

Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 

Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 

Sample Input
  
  
5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
 

Sample Output
  
  
It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH
 

Author
Ignatius.L


题目大意:
给定一个N×M的迷宫,求出从 左上角 走到 右下角 的最少时间,地图中”X"代表墙,"."代表空闲区域,数字1-9代表在这个位置需要额外花费的时间。

解题思路:
标准的bfs,使用priority_queue保证队列中花费时间的单调性(从小到大)。题目的难点在输出路径。方法很多:记录pre节点、pre方向等,我直接把路径作为状态加到队列中,原本以为会MLE,结果证明数据有点水。。数据中起点不会为数字。

参考代码:
#include <iostream>
#include <cstring>
#include <string>
#include <queue>
using namespace std;

const int MAXN = 110;
const int dx[4] = {-1, 0, 1, 0}, dy[4] = {0, 1, 0, -1};
string graph[MAXN];
int ans, n, m;
bool visited[MAXN][MAXN];

struct Point {
    int x, y;
    Point(int _x, int _y) : x(_x), y(_y) {}
};
vector<Point> path;

struct State {
    int x, y, step;
    vector<Point> path;
    State(int _x, int _y, int _step, vector<Point> _path) : x(_x), y(_y), step(_step), path(_path) {}
    bool operator<(const State &b) const {
        return step > b.step;
    }
};
priority_queue<State> q;

void init() {
    memset(visited, false, sizeof(visited));
    while (!q.empty()) q.pop();
    ans = -1;
    path.clear();
}

void input() {
    cin.ignore();
    for (int i = 0; i < n; i++) {
        getline(cin, graph[i]);
    }
}

void work() {
    path.push_back(Point(0, 0));
    q.push(State(0, 0, 0, path));
    visited[0][0] = true;

    while (!q.empty()) {
        State cur = q.top();
        q.pop();

        if (cur.x == n-1 && cur.y == m-1) {
            ans = cur.step;
            path = cur.path;
            return;
        }

        for (int i = 0; i < 4; i++) {
            int nx = cur.x + dx[i], ny = cur.y + dy[i];
            vector<Point> npath = cur.path;
            npath.push_back(Point(nx, ny));
            if (nx >= 0 && nx < n && ny >= 0 && ny < m) {
                if (!visited[nx][ny]) {
                    visited[nx][ny] = true;
                    if (graph[nx][ny] == '.') {
                        q.push(State(nx, ny, cur.step + 1, npath));
                    } else if (isdigit(graph[nx][ny])) {
                        q.push(State(nx, ny, cur.step + 1 + graph[nx][ny] - '0', npath));
                    }
                }
            }
        }
    }
}

void output() {
    if (ans == -1) {
        cout << "God please help our poor hero." << endl;
    } else {
        cout << "It takes " << ans << " seconds to reach the target position, let me show you the way." << endl;
        int cnt = 1;
        for (int i = 1; i < path.size(); i++) {
            cout << cnt++ << "s:" << '(' << path[i-1].x << ',' << path[i-1].y << ')' << "->" << '(' << path[i].x << ',' << path[i].y << ')' << endl;
            if (isdigit(graph[path[i].x][path[i].y])) {
                for (int j = 0; j < graph[path[i].x][path[i].y] - '0'; j++) {
                    cout << cnt++ << "s:FIGHT AT " << '(' << path[i].x << ',' << path[i].y << ')' << endl;
                }
            }
        }
    }
    cout << "FINISH" << endl;
}

int main() {
    ios::sync_with_stdio(false);
    while (cin >> n >> m) {
        init();
        input();
        work();
        output();
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值