HDU 2489 Minimal Ratio Tree(图论-最小生成树)

Minimal Ratio Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2367    Accepted Submission(s): 707


Problem Description
For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.




Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.
 

Input
Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the input. The next line contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the diagonal will be all 0, since there is no edge connecting a node with itself.



All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].

The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree. 

 

Output
For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number; if there's a tie, look at the second smallest node number, etc. Please note that the nodes are numbered from 1 .
 

Sample Input
  
  
3 2 30 20 10 0 6 2 6 0 3 2 3 0 2 2 1 1 0 2 2 0 0 0
 

Sample Output
  
  
1 3 1 2
 

Source
 

Recommend
gaojie


题目大意:

给你一张图n个点,每个点有权值,问你从中选出m个点,使得最小,输出方案。


解题思路:

用二进制取与不取来枚举选出m个点的方案,分母就确定了,分子越小越好,所以通过最小生成树算出。


参考代码:
#include <iostream>
#include <cstring>
using namespace std;

const int MAXN = 20;
const int INF = 0x3f3f3f3f;
int graph[MAXN][MAXN], weight[MAXN], dis[MAXN], pre[MAXN], n, m, ans;
long long ansEdge, ansNode;
bool valid[MAXN], v[MAXN];

int prim() {
    memset(v, false, sizeof(v));
    int u;
    for (int i = 1; i <= n; i++) {
        if (valid[i]) {
            u = i;
            break;
        }
    }
    v[u] = true;
    int edgeSum = 0;
    for (int i = 1; i <= n; i++) {
        if (valid[i]) {
            dis[i] = graph[u][i];
            pre[i] = u;
        }
    }
    for (int i = 1; i < m; i++) {
        u = -1;
        for (int j = 1; j <= n; j++) {
            if (valid[j] && !v[j]) {
                if (u == -1 || dis[u] > dis[j])
                    u = j;
            }
        }
        edgeSum += graph[pre[u]][u];
        v[u] = true;
        for (int j = 1; j <= n; j++) {
            if (valid[j] && !v[j]) {
                if (dis[j] > graph[u][j]) {
                    dis[j] = graph[u][j];
                    pre[j] = u;
                }
            }
        }
    }
    return edgeSum;
}

void init() {
    ansEdge = INF;
    ansNode = 0;
}

void input() {
    for (int i = 1; i <= n; i++) {
        cin >> weight[i];
    }
    for (int i = 1; i <= n; i++) {
        for (int j = 1; j <= n; j++) {
            cin >> graph[i][j];
            if (graph[i][j] == 0) {
                graph[i][j] = INF;
            }
        }
    }
}

void work() {
    for (int i = (1 << m) - 1; i < (1 << n); i++) {
        int cnt = 0;
        long long edge_cur = 0, node_cur = 0;
        memset(valid, false, sizeof(valid));
        for (int j = 1; j <= n; j++) {
            if (i & (1 << (j-1))) {
                cnt++;
                valid[j] = true;
                node_cur += weight[j];
            }
        }

        if (cnt == m) {
            edge_cur = prim();
            if (edge_cur * ansNode < ansEdge * node_cur) {
                ansEdge = edge_cur;
                ansNode = node_cur;
                ans = i;
            }
        }
    }
}

void output() {
    int cnt = 0;
    for (int i = 1; i <= n; i++) {
        if (ans & (1 << (i-1))) {
            if (cnt++) cout << " ";
            cout << i;
        }
    }
    cout << endl;
}

int main() {
    ios::sync_with_stdio(false);
    while (cin >> n >> m && (n || m)) {
        init();
        input();
        work();
        output();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值