UVa1185 - Big Number(求阶乘的位数)

In many applications very large integers numbers are required. Some of theseapplications are using keys for secure transmission of data, encryption, etc.In this problem you are given a number, you have to determine the number of digitsin the factorial of the number.

Input 

Input consists of several lines of integer numbers. The first line contains anintegern, which is the number of cases to be tested, followed byn lines,one integer 1 $ \leq$n $ \leq$ 107 on each line.

Output 

The output contains the number of digits in the factorial of the integers appearingin the input.

Sample Input 

2
10
20

Sample Output 

7
19
题意:给出一个数,求其阶乘的结果有多少位

思路:

#include <stdio.h>
#include <math.h>

int n;

void input()
{
	scanf("%d", &n);
}

void solve()
{
	double ans = 0;
	
	if (n == 1) {
		printf("1\n");
		return;
	}
	
	for (int i = n; i >= 1; i--) {
		ans += log10((double)i);
	}
	
	printf("%d\n", (int)ceil(ans));
}

int main()
{
#ifndef ONLINE_JUDGE
	freopen("d:\\OJ\\uva_in.txt", "r", stdin);
#endif

	int cas;
	scanf("%d", &cas);
	while (cas--) {
		input();
		solve();
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值