hdu1398 Square Coins(组合)


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 

Sample Input
  
  
2 10 30 0
 

Sample Output
  
  
1 4 27
题意:有19个硬币,币值分分别为1^2,2^2,...,17^2,给出一个不大于300的币值,问有多少种组合方法
思路:是组合问题,用母函数就可解决 先计算用用币值为1的组合数,然后计算用币值1,4的组合数,依此类推,直到用1,4,...,289构成所需币值的组合数
代码如下
import java.io.FileInputStream;
import java.io.OutputStreamWriter;
import java.io.InputStreamReader;
import java.io.PrintWriter;
import java.util.Scanner;

public class Main implements Runnable
{  
    private static final boolean DEBUG = false;
    private Scanner cin;
    private PrintWriter cout;
    private static final int N = 301;
    private static final int[] coins = new int[]{1, 4, 9, 16, 25, 36, 49, 64, 81, 100, 121, 144, 169, 196, 225, 256, 289};
    private static int n;
    private static int[] a = new int[N], b = new int[N];
   
    private void init()
    {
        try {
            if (DEBUG) {
                cin = new Scanner(new InputStreamReader(new FileInputStream("f:\\OJ\\uva_in.txt")));
            } else {
                cin = new Scanner(new InputStreamReader(System.in));
            }
            
            cout = new PrintWriter(new OutputStreamWriter(System.out));
            
           for (int i = 0; i < N; i++) {
               a[i] = 1;
               b[i] = 0;
           }
           
           for (int i = 1; i < 17; i++) {
               for (int j = 0; j < N; j++) {
                   for (int k = 0; j + k < N; k += coins[i]) {
                       b[j + k] += a[j];
                   }
               }
               
               for (int j = 0; j < N; j++) {
                   a[j] = b[j];
                   b[j] = 0;
               }
           }
        } catch (Exception e) {
            e.printStackTrace();
        }  
    }
    
    private boolean input()
    {
       n = cin.nextInt();
       if (n == 0) return false;
       
        return true;
    }
    
    private void solve()
    {
      cout.println(a[n]);
      cout.flush();
    }
    
    @Override
    public void run()
    {
        init();
        
        while (input()) 
        {
            solve();
        }
    }
    
    public static void main(String[] args) 
    {
        // TODO code application logic here
       new Thread(new Main()).start();
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值