HDU1398- Square Coins -母函数题解

                         Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                          Total Submission(s): 14295    Accepted Submission(s): 9823


 

Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

 

 

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

 

 

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

 

 

Sample Input

 

2 10 30 0

 

 

Sample Output

 

1 4 27

 

 

Source

Asia 1999, Kyoto (Japan)

 

 

Recommend

Ignatius.L   |   We have carefully selected several similar problems for you:  1028 2152 2082 1709 2079 

 

题目大意:要不还是直接复制翻译器翻译的把。。。

Silverland的人们使用方形硬币。 它们不仅具有方形形状,而且它们的值也是方形数字。 Silverland提供硬币,所有方形数字的值最高可达289(= 17 ^ 2),即1信用币,4信用币,9信用币,......和289信用币。
有四种硬币组合可以支付十个学分:

十个1信用币,
一个4学分硬币和六个1学分硬币,
两个4信用币和两个1信用币,和
一个9学分硬币和一个1学分硬币。

您的任务是计算使用Silverland硬币支付给定金额的方式数量。

思路:普通母函数问题,1到17的平方的金币是无限的,所以要用所求价值限定,其他的没了。。。

 代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#define N 301
using namespace std;
int a[N],b[N],i,j,k,last,last2,v[18],p;
int main()
{
    for(int i=1;i<=17;i++)
        v[i]=i*i;
    while(cin>>p&&p!=0)
    {
        memset(a,0,sizeof(a));
        a[0]=1;
        for(i=1;i<=17;i++)
        {
            memset(b,0,sizeof(b));
            for(j=0;j*v[i]<=p;j++)
                for(k=0;k+j*v[i]<=p;k++)
                    b[k+j*v[i]]+=a[k];
            memcpy(a,b,sizeof(b));
        }
        cout<<a[p]<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值