H-Find them, Catch them POJ 1703

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
   
   
1
5 5
A 1 2
D 1 2
D 2 4
A 1 2
A 1 4
Sample Output
   
   
Not sure yet.
In different gangs.
In the same gang.


Status Accepted
Time 391ms
Memory 948kB
Length 1448
Lang C++
Submitted
Shared
RemoteRunId 16382347
Select Code
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stdio.h>
using namespace std;
int m,n;
struct note
{
    int fu;
    int opp;
};
struct note f[100050];
void init()
{
    int i;
    for(i=1;i<=n;i++)
    {
        f[i].fu=i;
        f[i].opp=-1;
    }

    return;
}
int getf(int v)
{
    if(v==f[v].fu)
        return v;
    else
    {
        f[v].fu=getf(f[v].fu);
        return f[v].fu;
    }
}
int merge(int u,int v)
{
    int t1,t2;
    t1=getf(u);
    t2=getf(v);
    if(t1!=t2)
    {
       f[t2].fu=t1;
       return 1;
    }
    return 0;
}
int main()
{
   int t,k,i,u,v,tv,tu;
   char s[3];
   scanf("%d",&t);
   for(k=1;k<=t;k++)
   {
       scanf("%d%d",&n,&m);
       init();
       for(i=1;i<=m;i++)
       {
           scanf("%s",s);
           scanf("%d%d",&u,&v);
           tu=getf(u);
           tv=getf(v);
           if(s[0]=='A')
           {
               if(tu==tv)
                  printf("In the same gang.\n");
               else if(f[tu].opp==tv||f[tv].opp==tu)
                 printf("In different gangs.\n");
               else
                printf("Not sure yet.\n");
           }
           else if(s[0]=='D')
           {
               if(f[tu].opp!=-1)
                  merge(tv,f[tu].opp);   //红色处若将tv和f[tu].opp的位置互换则不能ac
               if(f[tv].opp!=-1)         //因为tv和tu不再是boss,蓝色代码也就没有意义
                  merge(tu,f[tv].opp);
               f[tu].opp=tv;
               f[tv].opp=tu;
           }
       }

   }
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值