hdu4221 Greedy

Greedy?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2454    Accepted Submission(s): 823


Problem Description
iSea is going to be CRAZY! Recently, he was assigned a lot of works to do, so many that you can't imagine. Each task costs Ci time as least, and the worst news is, he must do this work no later than time Di!
OMG, how could it be conceivable! After simple estimation, he discovers a fact that if a work is finished after Di, says Ti, he will get a penalty Ti - Di. Though it may be impossible for him to finish every task before its deadline, he wants the maximum penalty of all the tasks to be as small as possible. He can finish those tasks at any order, and once a task begins, it can't be interrupted. All tasks should begin at integral times, and time begins from 0.
 

Input
The first line contains a single integer T, indicating the number of test cases.
Each test case includes an integer N. Then N lines following, each line contains two integers Ci and Di.

Technical Specification
1. 1 <= T <= 100
2. 1 <= N <= 100 000
3. 1 <= Ci, Di <= 1 000 000 000
 

Output
For each test case, output the case number first, then the smallest maximum penalty.
 

Sample Input
  
  
2 2 3 4 2 2 4 3 6 2 7 4 5 3 9
 

Sample Output
  
  
Case 1: 1 Case 2: 3
 
注意:求得是没有按时完成的任务罚金最多的那个!
思路:按照截止时间从小到大来排序,从第一天开始做任务,每个任务的完成时间减去截止时间相对来说最少
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define MAXN 100010
using namespace std;
struct work{
	int c;
	int d;
}a[MAXN];
int cmp(work x, work y){
	return x.d < y.d;
}
int main(){
	int t, n;
	int flag = 1;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		for(int i = 0; i < n; i++){
			scanf("%d%d", &a[i].c, &a[i].d);
		}
		sort(a, a+n, cmp);
		long long k = 0, ans = 0;
		for(int i = 0; i < n; i++){
			k = k+a[i].c;  //任务的完成时间	
			ans = max(ans, k-a[i].d);
		}
		printf("Case %d: %lld\n", flag, ans);
		flag++;
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值