Problem F: 统计单词数

Problem F: 统计单词数

Time Limit: 1 Sec   Memory Limit: 32 MB
Submit: 7394   Solved: 3264
[ Submit][ Status][ Web Board]

Description

给一个句子,统计这个句子中有多少个单词。单词可能包含大写字母、小写字母、数字和其他符号,单词之间用空白符或标点符号隔开。

Input

有多组数据,每个句子占一行,句子长度不超过1000个字符,到文件尾结束。

Output

每个句子对应一个整数,代表这个句子中有多少个单词,每个整数占一行

Sample Input

Meep....meep!How are you?

Sample Output

23

HINT

Append Code



#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <ctype.h>
int main()
{
     char str[1100];
     while ( gets (str)!=NULL)
     {
         int i,count=0,len;
        len= strlen (str);
       for (i=0;i<len;i++)
       {
           if (ispunct(str[i])|| isspace (str[i]))
           {
               while (ispunct(str[i])|| isspace (str[i]))
                 i++;
           }
           else
           {
               while (!ispunct(str[i])&&! isspace (str[i]))
                 i++;
               count++;
           }
  
  
  
       }
         printf ( "%d\n" ,count);
  
     }
  
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值