HDU 1045

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11682    Accepted Submission(s): 7005


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 


Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
   
   
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
   
   
5 1 5 2 4
 

Source

题目的意思是在一个N*N的方格中要放置几个大炮,这些大炮不能再同一直线上,如果中间有墙壁挡着则可以,问最多可以摆放多少个大炮(类似于N皇后的问题,个人认为比那个要简单一点)
深搜比较简单吧

#include<bits/stdc++.h>
using namespace std;
char a[6][6];
int n,t;
int max1;
bool YN(int x,int y)
{
    for(int i=x-1;i>=0;i--)
    {
        if(a[i][y]=='#') return false;
        if(a[i][y]=='X') break;
    }
    for(int j=y-1;j>=0;j--)
    {
        if(a[x][j]=='#')return false;
        if(a[x][j]=='X') break;
    }
    return true;
}
void dfs(int count,int s)
{
    if(count==n*n)
    {
        if(s>max1)
            max1=s;
        return ;
    }
    int x=count/n;
    int y=count%n;
    if(a[x][y]=='.'&&YN(x,y))
    {
        a[x][y]='#';
        dfs(count+1,s+1);
        a[x][y]='.';
        dfs(count+1,s);
    }
    else
        dfs(count+1,s);
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        max1=0;
        if(n==0)
            return 0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                cin>>a[i][j];
            }
        }
        dfs(0,0);
        cout<<max1<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值