XTU 1206 Dormitory's Elevator

Dormitory's Elevator

Accepted : 52 Submit : 332
Time Limit : 1000 MS Memory Limit : 65536 KB

Problem Description

The new dormitory has N(1≤N≤100000) floors and M(1≤M≤100000)students. In the new dormitory, in order to save student's time as well as encourage student exercise, the elevator in dormitory will not stop in adjacent floor. So if there are people want to get off the elevator in adjacent floor, one of them must walk one stair instead. Suppose a people go down 1 floor costs A energy, go up 1 floor costs B energy(1≤A,B≤100). Please arrange where the elevator stop to minimize the total cost of student's walking cost.All students and elevator are at floor 1 initially, and the elevator can not godown and can stop at floor 2.

Input

First line contain an integer T, there are T(1≤T≤10) cases. For each case T, there are two lines. First line: The number of floors N(1≤N≤100000), and the number of students M(1≤M≤100000),A,B(1≤A,B≤100) Second line: M integers (2≤A[i]≤N), the student's desire floor.

Output

Output case number first, then the answer, the minimum of the total cost of student's walking cost.

Sample Input
1
3 2 1 1
2 3

Sample Output
Case 1: 1



#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 100009
#define ll __int64
using namespace std;

ll dp[N];//表示从第一层到第n层的最小体力耗费
int a[N];
int n,m,A,B;

//想要少走,那么就要尽可能多的让电梯停下来
//如果现在在第i层,那么上一次停靠可以是第i-2,或者第i-3层(因为要多停)

int main()
{

    int t;
    scanf("%d",&t);

    for(int ca=1;ca<=t;ca++)
    {
        scanf("%d %d %d %d",&n,&m,&A,&B);

        int ff;
        memset(a,0,sizeof a);
        memset(dp,0,sizeof dp);

        for(int i=0;i<m;i++)
        {
            scanf("%d",&ff);
            a[ff]++;
        }
        dp[1]=0;
        dp[2]=0;//可以停在二楼

        //dp[2]=min(A,B)*a[2];
        //dp[3]=a[2]*A;

        for(int i=3;i<=n;i++)
        {
            ll tt=1<<30;

            ll ff=dp[i-2]+min(A,B)*a[i-1];//当上一次是i-2停时,要去i-1的人,可以选择i下或者i-2的时候下,选小的。
            if(i-3>0)
             tt=dp[i-3]+min(2*B*a[i-1]+B*a[i-2],min( A*a[i-1]+A*a[i-2]*2, min(A*a[i-1]+B*a[i-2],A*a[i-2]*2+B*a[i-1]*2 ) ));
//当上一次是i-3层停时,那么会有下面四种选择
//(i-3->i-1,i-3->i-2); (i->i-1,i->i-2); (i->i-1,i-3->i-2); (i->i-2,i-3->i-1)
            dp[i]=min(ff,tt);
        }

        printf("Case %d: %I64d\n",ca,dp[n]);

    }

    return 0;
}

/*
3
4 8 1 2
1 1 2 2 3 3 4 4
*/
//2



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值