HDu 1198 Farm Irrigation

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7427    Accepted Submission(s): 3185


Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC
FJK
IHE

then the water pipes are distributed like 


Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
 

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
 

Output
For each test case, output in one line the least number of wellsprings needed.
 

Sample Input
  
  
2 2 DK HF 3 3 ADC FJK IHE -1 -1
 

Sample Output
  
  
2 3

题意:告诉几个田,如果有管道联通则可以灌溉,问最少需要几个灌溉器

分析,主要就是求联通块,一个联通块一个灌溉器,直接求需要几个联通块就可以了。

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;
char s[1009][1009];
int vis[1009][1009];
int m,n;

int dis[4][2]={0,1,0,-1,1,0,-1,0};//右左下上
int up[]={1,1,0,0,1,0,1,1,0,1,1};
int dw[]={0,0,1,1,1,0,0,1,1,1,1};
int le[]={1,0,1,0,0,1,1,1,1,0,1};
int ri[]={0,1,0,1,0,1,1,0,1,1,1};

void dfs(int x,int y)
{
    if(vis[x][y]) return;
    vis[x][y]=1;

    for(int i=0;i<4;i++)
    {
        int xx=x+dis[i][0];
        int yy=y+dis[i][1];

        if(xx<0 || xx>=m || yy<0 || yy>=n)continue;
        if(i==0 && ri[s[x][y]-'A'] && le[s[xx][yy]-'A']) dfs(xx,yy);
        if(i==1 && le[s[x][y]-'A'] && ri[s[xx][yy]-'A']) dfs(xx,yy);
        if(i==2 && dw[s[x][y]-'A'] && up[s[xx][yy]-'A']) dfs(xx,yy);
        if(i==3 && up[s[x][y]-'A'] && dw[s[xx][yy]-'A']) dfs(xx,yy);
    }
}

int main()
{

    while(~scanf("%d%d",&m,&n))
    {
        if(n<0 || m<0 )break;
        memset(vis,0,sizeof vis);

        for(int i=0;i<m;i++)
            scanf("%s",s[i]);

        int ans=0;
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
                if(vis[i][j]==0)
                {
                    ans++;
                    dfs(i,j);
                }

                printf("%d\n",ans);

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值