POJ1860 Currency Exchange 最短路bellman-ford

Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 23456 Accepted: 8489

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

告诉n中货币互相兑换的手续费和汇率,现在有s货币数量为V,问是否存在兑换方式使得货币数量变多,从一种货币兑换到另外一种货币,用(V-c)* R就是兑换后的货币数量

问题可以转换成从一个源点出发,问是否存在一个正环。可以用bellman-ford来写


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
using namespace std;

int vis[1009];
double dis[1009];
int n,m,s;
double V;

struct Node
{
    int u,v;
    double r,c;
}f[1009];
int flag;

void bellman_ford(int cnt)
{
    memset(dis,0,sizeof dis);
    dis[s]=V;


    for(int i=0;i<n-1;i++)//找最多n-1条边的最长路
    {
        for(int j=0;j<cnt;j++)
            dis[f[j].v]=max(dis[f[j].v],(dis[f[j].u]-f[j].c)*f[j].r);
    }

    for(int j=0;j<cnt;j++)//判断是否能形成正环
            if( dis[f[j].v] < (dis[f[j].u]-f[j].c)*f[j].r )
           {
               flag=1;
               return;
           }

}

int main()
{
    while(~scanf("%d%d%d%lf",&n,&m,&s,&V))
    {
        int cnt=0;
        int a,b;
        double r1,c1,r2,c2;

        for(int i=0;i<m;i++)
        {
            scanf("%d%d%lf%lf%lf%lf",&a,&b,&r1,&c1,&r2,&c2);
            f[cnt].u=a;
            f[cnt].v=b;
            f[cnt].r=r1;
            f[cnt++].c=c1;
            f[cnt].u=b;
            f[cnt].v=a;
            f[cnt].r=r2;
            f[cnt++].c=c2;
        }

        flag=0;

        bellman_ford(cnt);

        if(flag)
            puts("YES");
        else
            puts("NO");
    }

    return 0;
}













评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值