hdu 4474 Yet Another Multiple Problem

Yet Another Multiple Problem

Time Limit: 40000/20000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4962    Accepted Submission(s): 1087


Problem Description
There are tons of problems about integer multiples. Despite the fact that the topic is not original, the content is highly challenging. That’s why we call it “Yet Another Multiple Problem”.
In this problem, you’re asked to solve the following question: Given a positive integer n and m decimal digits, what is the minimal positive multiple of n whose decimal notation does not contain any of the given digits?
 

Input
There are several test cases.
For each test case, there are two lines. The first line contains two integers n and m (1 ≤ n ≤ 10 4). The second line contains m decimal digits separated by spaces.
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) while Y is the minimal multiple satisfying the above-mentioned conditions or “-1” (without quotation marks) in case there does not exist such a multiple.
 

Sample Input
  
  
2345 3 7 8 9 100 1 0
 

Sample Output
  
  
Case 1: 2345 Case 2: -1
 


题意:告诉一个数n,以及k个数字,求一个n的整数倍,并且这个倍数中不存在这k个数,求最小的倍数值。

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;

typedef __int64 ll;

struct Node
{
    int yu;
    int digit;
    int pre;
    int id;
}f[1000009];

queue<int>q;
int use[20];
int vis[1000009];
ll n;
int k;
int cnt;
int ca;
void output(int id)//数字可能很大,递归输出
{
    if(f[id].pre==-1)return;
    output(f[id].pre);
    printf("%d",f[id].digit);
}

int bfs()
{
    f[0].yu=0;
    f[0].pre=-1;
    f[0].id=0;
    q.push(0);
    int t;
    cnt=1;

    while(!q.empty())
    {
        t=q.front();
        q.pop();

        for(int i=0;i<=9;i++)
        {
            if(use[i]) continue;
            if(f[t].yu==0 && i==0) continue;

            int yu=(f[t].yu*10+i)%n;
            if(vis[yu]) continue;

            if(yu==0)
            {
                printf("Case %d: ",ca);
                output(t);
                printf("%d\n",i);
                return 1;
            }
            vis[yu]=1;
            f[cnt].digit=i;
            f[cnt].id=cnt;
            f[cnt].yu=yu;
            f[cnt].pre=t;
            q.push(cnt++);
        }
    }
    return -1;
}


int main()
{
    ca=1;
    while(~scanf("%I64d%d",&n,&k))
    {
        memset(vis,0,sizeof vis);
        memset(use,0,sizeof use);

        for(int i=0;i<k;i++)
        {
            int a;
            scanf("%d",&a);
            use[a]=1;
        }

        while(!q.empty()) q.pop();

        int flag=bfs();

       if(flag==-1)
       {
           printf("Case %d: ",ca);
            puts("-1");
       }
       ca++;
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值