POJ3279 Fliptile

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6336 Accepted: 2410

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题意:1表示黑面,0表示白面,要把所有的黑面变成白面,翻转某一块,可以使它周围四块都翻转。如果能使得最终都为白色就输出最小的翻转步数,如果不能满足就输出IMPOSSIBLE。

思路:如果一一枚举,复杂度就是2^(n*m),然后可以通过二进制枚举的方式来降低复杂度。枚举第一行(1<<n)种情况(每个位置翻转或不翻转),从第二行开始,每次讨论它的上一行同列位置是否为黑色,如果是黑色那么当前位置一定要翻转。


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

int m,n;
int a[20][20];
int flag;
int ans[20][20],flip[20][20];
int dis[5][2]={0,0,0,1,0,-1,1,0,-1,0};

int check(int x,int y)  //判断当前这个位置是否为黑色 
{
	int tmp=a[x][y];
	for(int i=0;i<5;i++)
	{
		int xx=x+dis[i][0];
		int yy=y+dis[i][1];
		
		if(xx<0 || xx>=m || yy<0 || yy>=n) continue;
		
		tmp+=flip[xx][yy];
	}
	tmp=tmp&1;    //判断奇偶性 ,奇数则表示为黑色1 
	return tmp;
}

int fun()
{
	for(int i=1;i<m;i++)
	{
		for(int j=0;j<n;j++)
		{
			if(check(i-1,j))//对于当前位置(i,j),每次判断(i-1,j)的位置是不是为白色0 
			flip[i][j]=1; //不是则要翻转 
		}
	}
	
	for(int i=0;i<n;i++)
	{
		if(check(m-1,i))//判断下最后一行是不是都为白色0 
		return 9999999;
	}
	
	int num=0;
	for(int i=0;i<m;i++)
	{
		for(int j=0;j<n;j++)
		{
			num+=flip[i][j];
		}
	}
	return num;
}

int main()
{
	while(~scanf("%d%d",&m,&n))
	{
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
			{
				scanf("%d",&a[i][j]);
			}
		
		memset(ans,0,sizeof ans);
		
		flag=0;
		int tmp=999999;
		int res;
		
		for(int i=0;i<(1<<n);i++)
		{
			memset(flip,0,sizeof flip);
			
			for(int j=0;j<n;j++)
			flip[0][j]=(i>>j)&1; //判断枚举的第j个位置是否进行翻转操作 
			
			res=fun();
			if(res<tmp)  //求最小值 
			{
				tmp=res;
				for(int j=0;j<m;j++)
				for(int k=0;k<n;k++)
				ans[j][k]=flip[j][k];
			}
		}
		
		
		if(tmp==999999)
		puts("IMPOSSIBLE");
		else
		{
			for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				printf("%d%c",ans[i][j],j==n-1?'\n':' ');
		}
		
	}	
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值