POJ 2318(计算几何 )

问题描述:

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

题目题意:题目给我们一个矩形的左上角和右下角的顶点,然后给我们N条矩形内部的线段把矩形划分成N+1块,给我们M个点的坐标,问我们每个区间里的点的个数。

题目分析:这道题目主要利用的就是用叉乘来判断点在直线的那一侧

假设点A 直线BC

A         。 B   

     。

     C

那么我们连接AC 如果CB向量叉乘CA向量大于0在上侧,等于0在CB上,小于0在CB下侧。

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;

struct note//保存线段的上下俩个点
{
    int xup,xdown;
}card[5005];
struct Note//玩具的坐标
{
    int x,y;
}toy[5005];

bool vis[5005];
int ans[5005];
int ymax,ymin;

int cross(int a,int b)
{
    return -(toy[b].x-card[a].xdown)*(ymax-ymin)+(toy[b].y-ymin)*(card[a].xup-card[a].xdown);
}
int main()
{
    int n,m,x1,y1,x2,y2;
    while (scanf("%d",&n)!=EOF) {
        if (n==0) break;
        memset (ans,0,sizeof (ans));
        memset (vis,false,sizeof(vis));
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        ymax=y1,ymin=y2;
        for (int i=0;i<n;i++)
            scanf("%d%d",&card[i].xup,&card[i].xdown);
        for (int i=0;i<m;i++)
            scanf("%d%d",&toy[i].x,&toy[i].y);
        for (int i=0;i<n;i++) {
            for (int j=0;j<m;j++) {
                if (!vis[j]&&cross(i,j)>0) {
                   ans[i]++;
                   vis[j]=true;//标记一下,避免前面的被后面的线段重复计算
                }
            }
        }
        ans[n]=m;
        for (int i=0;i<n;i++)
            ans[n]-=ans[i];
        for (int i=0;i<=n;i++) {
            printf("%d: %d\n",i,ans[i]);
        }
        printf("\n");
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值