HDU 4445(计算几何+暴力)

问题描述:

Crazy Tank was a famous game about ten years ago. Every child liked it. Time flies, children grow up, but the memory of happy childhood will never go. 

Now you’re controlling the tank Laotu on a platform which is H meters above the ground. Laotu is so old that you can only choose a shoot angle(all the angle is available) before game start and then any adjusting is not allowed. You need to launch N cannonballs and you know that the i-th cannonball’s initial speed is Vi. 
On the right side of Laotu There is an enemy tank on the ground with coordination(L1, R1) and a friendly tank with coordination(L2, R2). A cannonball is considered hitting enemy tank if it lands on the ground between [L1,R1] (two ends are included). As the same reason, it will be considered hitting friendly tank if it lands between [L2, R2]. Laotu's horizontal coordination is 0. 
The goal of the game is to maximize the number of cannonballs which hit the enemy tank under the condition that no cannonball hits friendly tank. 
The g equals to 9.8.

Input

There are multiple test case. 
Each test case contains 3 lines. 
The first line contains an integer N(0≤N≤200), indicating the number of cannonballs to be launched. 
The second line contains 5 float number H(1≤H≤100000), L1, R1(0<L1<R1<100000) and L2, R2(0<L2<R2<100000). Indicating the height of the platform, the enemy tank coordinate and the friendly tank coordinate. Two tanks may overlap. 
The third line contains N float number. The i-th number indicates the initial speed of i-th cannonball. 
The input ends with N=0.

Output

For each test case, you should output an integer in a single line which indicates the max number of cannonballs hit the enemy tank under the condition that no cannonball hits friendly tank.

Sample Input

2
10 10 15 30 35
10.0
20.0
2
10 35 40 2 30
10.0
20.0
0
Sample Output

1
0

题目题意:题目给我们一个炮台高度H,N枚炮弹,让我们设计一个角度使得更多的炮弹落在[L1,R1],不允许落到[L2,R2]区间内。

题目分析:我们枚举在y轴正方向到y轴负方向内的角度(每一次加上一个小角度)。算出每个角度时,符合要求的炮弹量。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

const double g=9.80;
const double PI=acos(-1.0);
const double epx=PI/1000;
const int maxn=205;
double v[maxn],x[maxn];
double H,L1,R1,L2,R2;
int n,ans;

void solve(double angle)
{
    int cur=0;
    for (int i=0;i<n;i++) {
        double res=sqrt(v[i]*v[i]*cos(angle)*cos(angle)+2*g*H);
        double t=(v[i]*cos(angle)+res)/g;
        x[i]=v[i]*sin(angle)*t;
    }
    for (int i=0;i<n;i++) {
        if (x[i]>=L1&&x[i]<=R1)
            cur++;
        if (x[i]>=L2&&x[i]<=R2) {//只要有炮弹落在这里,就不符合要求
            cur=0;
            break;
        }
    }
    ans=max(ans,cur);
}
int main()
{
    while (scanf("%d",&n)!=EOF) {
        if(n==0) break;
        scanf("%lf%lf%lf%lf%lf",&H,&L1,&R1,&L2,&R2);
        for (int i=0;i<n;i++)
            scanf("%lf",&v[i]);
        ans=0;
        for (double i=0;i<=PI;i+=epx) {
            solve (i);
        }
        printf("%d\n",ans);
    }
    return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值