hdu4445 物理枚举

Crazy Tank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2729    Accepted Submission(s): 486


Problem Description
Crazy Tank was a famous game about ten years ago. Every child liked it. Time flies, children grow up, but the memory of happy childhood will never go.

Now you’re controlling the tank Laotu on a platform which is H meters above the ground. Laotu is so old that you can only choose a shoot angle(all the angle is available) before game start and then any adjusting is   not allowed. You need to launch N cannonballs and you know that the i-th cannonball’s initial speed is Vi.
On the right side of Laotu There is an enemy tank on the ground with coordination(L1, R1) and a friendly tank with coordination(L2, R2). A cannonball is considered hitting enemy tank if it lands on the ground between [L1,R1] (two ends are included). As the same reason, it will be considered hitting friendly tank if it lands between [L2, R2]. Laotu's horizontal coordination is 0.
The goal of the game is to maximize the number of cannonballs which hit the enemy tank under the condition that no cannonball hits friendly tank.
The g equals to 9.8.
 

Input
There are multiple test case.
Each test case contains 3 lines.
The first line contains an integer N(0≤N≤200), indicating the number of cannonballs to be launched.
The second line contains 5 float number H(1≤H≤100000), L1, R1(0<L1<R1<100000) and L2, R2(0<L2<R2<100000). Indicating the height of the platform, the enemy tank coordinate and the friendly tank coordinate. Two tanks   may overlap.
The third line contains N float number. The i-th number indicates the initial speed of i-th cannonball.
The input ends with N=0.
 

Output
For each test case, you should output an integer in a single line which indicates the max number of cannonballs hit the enemy tank under the condition that no cannonball hits friendly tank.
 

Sample Input
  
  
2 10 10 15 30 35 10.0 20.0 2 10 35 40 2 30 10.0 20.0 0
 

Sample Output
  
  
1 0
无语啊,枚举就能过,当时还想什么二分三分,线段树,……。
#include <stdio.h>
#include <math.h>
#include <iostream>
using namespace std;
const double PI=acos(-1);
double h,l1,l2,r1,r2,g=9.8;
int n;
double v[202];
int fmax(int a,int b)
{
    if(a>b)
    return a;
    return b;
}
int ff(double x)
{
    int i,sum=0;
    for(i=1;i<=n;i++)
    {
       double x1=v[i]*cos(x);
       double x2=v[i]*sin(x);
       double x3=sqrt(2*h*g+x2*x2);
       double x4=(x3-x2)/g*x1;
       if(x4>=l2&&x4<=r2)
       {
           return 0;
       }
       if(x4>=l1&&x4<=r1)
       {
           sum++;
       }
    }
    return sum;
}
int main ()
{
    int i;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
        break;
        scanf("%lf%lf%lf%lf%lf",&h,&l1,&r1,&l2,&r2);
        for(i=1;i<=n;i++)
        {
                scanf("%lf",&v[i]);
        }
        double x;
        double add=PI/1000.0;
        int max=-1;
        for(x=-PI/2.0;x<=PI/2.0;x+=add)
        {
            max=fmax(max,ff(x));
        }
        printf("%d\n",max);
    }
    return 0;
}

 

Source

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值