Ants
Time Limit: 1000MS | | Memory Limit: 30000K |
Total Submissions: 12474 | | Accepted: 5478 |
Description
An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input
The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output
For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.
Sample Input
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output
4 8
38 207
题意分析:
n只蚂蚁以每秒1cm的速度在长为Lcm的竿子上爬行。当蚂蚁爬到竿子的端点就会掉落。由于竿子太细,两只蚂蚁相遇时只能各自反向爬回去。对于每只蚂蚁,我们知道它距离左端的距离为xi,但不知道它当前的朝向。计算所有蚂蚁掉下去的最短时间和最长时间。
解题思路:
最短时间时,所有蚂蚁都朝向离自己最近的端点走,这时候不会相撞,最短时间即为最后一个蚂蚁掉落需要的时间。
最长时间时,此时蚂蚁就应该出现相撞情况,当蚂蚁相撞时,两个都反向爬行,相当于两个都朝着原来的方向继续运动,即为它们相遇后保持原样交错而过继续前进而不会有任何问题,这样看起来,可以认为每只蚂蚁都是独立运动的,所以要求最长时间,只需要求蚂蚁到竿子端点的最大距离就好了。
代码如下
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<math.h>
#define M(i,n,m) for(int i = n;i < m;i ++)
#define N(n,m) memset(n,m,sizeof(n));
const int maxx = 1000001;
using namespace std;
int a[maxx];
int main()
{
int L,n,T;
cin >> T;
while(T --)
{
cin >> L >> n;
M(i,0,n)
scanf("%d",&a[i]);
int ma = 0;
M(i,0,n) ///找出所有最大距离中最大的值,即为题目要求的最小值
ma = max(ma,max(a[i],L - a[i]));
int mi = 0;
M(i,0,n)
mi = max(mi,min(a[i],L - a[i])); ///找出所有最小距离中最大的值,即为题目要求的最小值
printf("%d %d\n",mi,ma);
}
}