HDU1010奇偶剪枝DFS

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 101388    Accepted Submission(s): 27470


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 

Author
ZHANG, Zheng


从起点S到终点D,在规定时间内正好到达,涉及到奇偶剪枝的问题,

奇偶剪枝:

现假设起点为(sx,sy),终点为(ex,ey),给定t步恰好走到终点

s
       
|
       
|
       
|
       
+
e
如图所示(“|”竖走,“—”横走,“+”转弯),易证abs(ex-sx)+abs(ey-sy)为此问题类中任意情况下,起点到终点的最短步数,记做step,此处step1=8;
如果,此最短距离上有一些障碍物不能走,那么移动会偏移最短距离,但是不管偏移几个点,偏移后的距离都是最短距离加上一个偶数距离,这也是可以证明的!

s
 
 
+
 
|
+
     
|
       
+
e
如图,为一般情况下非最短路径的任意走法举例,step2=14;
step2-step1=6,偏移路径为6,偶数(易证);
你发现偏离最短路径导致增加的长度其实只会是偶数!
所以,如果剩余时间减去最短路径,得到一个奇数,那么显然是无法在t时刻准时到达逃生门的!这种情况下,当然不在搜索,直接返回,以节省时间.
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>

using namespace std;

char map[1010][1010];
bool vis[1010][1010];
int n,m,k,wall;
bool flag;
int s[4][2] = {{0,1},{1,0},{0,-1},{-1,0}};
int sx,sy,ex,ey;

void DFS(int x,int y,int count)
{
    if(flag)
        return;
    ///边界控制
    if(x < 1 || x > n || y < 1 || y > m)
        return;
    if(count == k && x == ex && y == ey)///找到终点
    {
        flag = 1;
        return;
    }
    ///剪枝
    ///count表示已经走的时间,temp表示还有多少时间可以走
    int temp = k - count - fabs(x - ex) - fabs(y - ey);///fabs(x - ex)+fabs(y - ey)表示当前点到终点还要走的时间
    if(temp < 0 || temp & 1)    ///看能否到达终点,temp&1则是判断其是否偶数,根据LCY的奇偶性剪枝可得tem必须是偶数,是奇数则不行
        return;

    for(int i = 0;i < 4;i ++)
    {
        int tx = x + s[i][0];
        int ty = y + s[i][1];
        if(tx < 1 || tx > n || ty < 1 || ty > m || map[tx][ty] == 'X' || vis[tx][ty])
            continue;
        vis[tx][ty] = 1;
        DFS(tx,ty,count + 1);
        vis[tx][ty] = 0;
    }
}

int main()
{
    while(scanf("%d%d%d",&n,&m,&k) && n&&m&&k)
    {
        wall = 0;
        getchar();
        for(int i = 1;i <= n;i ++)
        {
            for(int j = 1;j <= m;j ++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j] == 'X')
                    ++ wall;
                if(map[i][j] == 'S')///起点
                {
                    sx = i;
                    sy = j;
                }
                else if(map[i][j] == 'D')///终点
                {
                    ex = i;
                    ey = j;
                }
            }
            getchar();
        }
        ///总共的点数减去墙的数量减去起点判断还可以走的是否小于k
        if(n*m - wall - 1 < k)
        {
            printf("NO\n");
            continue;
        }
        memset(vis,0,sizeof(vis));
        flag = 0;
        vis[sx][sy] = 1;
        DFS(sx,sy,0);
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值