HDU3732 01背包转化为多重背包

Ahui Writes Word

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2738    Accepted Submission(s): 971


Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.
 

Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)
 

Output
Output the maximum value in a single line for each test case.
 

Sample Input
  
  
5 20 go 5 8 think 3 7 big 7 4 read 2 6 write 3 5
 

Sample Output
  
  
15
Hint
Input data is huge,please use “scanf(“%s”,s)”
 

Author
Ahui
 

Source


题意:读题可知,每个单词只能出现一次,每个单词对应有价值和复杂度,很容易就可以想到是01背包的问题,可是普通的01背包肯定会超时,N*C<=10^9,数据量太大,但是每个单词的复杂度和价值都是介于0~10之间的,所以可以通过他们把01背包转化为多重背包。
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <string>
#include <stdlib.h>
#include <vector>
#include <map>
#include <set>
const int MAX = 0x3f3f3f3f;
const int MIN = -1<<28;
const int INF = 0x3f3f3f3f;
#define L(n,m) memset(n,m,sizeof(n);
#define M(i,n,m) for(int i = n;i < m;i ++)
using namespace std;

int n,C;
int a[11][11];
int dp[10010];
char s[10];

inline void ZERO_ONE_PACK(int value,int weight)
{
    for(int i = C;i >= weight;i --)
        dp[i] = max(dp[i],dp[i - weight] + value);
}

inline void COMPLETE_PACK(int value,int weight)
{
    for(int i = weight;i <= C;i ++)
        dp[i] = max(dp[i],dp[i - weight] + value);
}

void MULTIPLY_PACK(int value,int weight,int num)
{
    if(weight * num >= C)
    {
        COMPLETE_PACK(value,weight);
        return;
    }
    else
    {
        int k = 1;
        while(k <= num)
        {
            ZERO_ONE_PACK(k * value,k * weight);
            num -= k;
            k<<=1;
        }
        if(num)
            ZERO_ONE_PACK(num * value,num * weight);
        return;
    }
}

int main()
{
    int x,y;///x表示价值,y表示复杂度
    while(~scanf("%d%d",&n,&C))
    {
        memset(a,0,sizeof(a));
        for(int i = 0; i < n; i ++)
        {
            scanf("%s%d%d",s,&x,&y);
            a[x][y] ++;
        }
        memset(dp,0,sizeof(dp));
        for(int i = 0; i < 11; i ++)///价值
            for(int j = 0; j < 11; j ++)
                if(a[i][j])
                    MULTIPLY_PACK(i,j,a[i][j]);
        printf("%d\n",dp[C]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值