CSU->1040: Round-number

6 篇文章 0 订阅

1040: Round-number

             Time Limit: 1 Sec     Memory Limit: 64 Mb   

Description

Most of the time when rounding a given number, it is customary to round to some multiple of a power of 10. However, there is no reason why we cannot use another multiple to do our rounding to. For example, you could round to the nearest multiple of 7, or the nearest multiple of 3.
Given an int n and an int b, round n to the nearest value which is a multiple of b. If n is exactly halfway between two multiples of b, return the larger value.

Input

Each line has two numbers n and b,1<=n<=1000000,2<=b<=500

Output

The answer,a number per line.

Sample Input

5 10
4 10

Sample Output

10
0

Hint

Source

中南大学2012年暑期集训队选拔赛

题目链接:http://acm.csu.edu.cn/csuoj/problemset/problem?pid=1040

题解:题意就是按照b的值来四舍五入,但要注意的是,b可能是奇数。

AC代码:

#include<iostream>
using namespace std;

int main(){
    int n,b;
    while(scanf("%d%d",&n,&b)!=EOF){
        int num=(n/b)*b;
        if(2*(n%b)>=b){     //b可能是奇数 
            num+=b;
        }
        printf("%d\n",num);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值