HDU - 5973 HDU - 5973 威佐夫博弈,高精度BigDecimal

#####Description
Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?
#####Input
Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.
#####Output
For each test data,output answer on one line.1 means you are the winner,otherwise output 0.
#####Sample Input
2 1
8 4
4 7
#####Sample Output
0
1
0

####分析:

典型的Wythoff,直接应用wythoff博弈的判定方法。但要注意的是,这里的精度需要达到10^100,用java的BigDecimal实现。学习了别人的代码。

####知识点:
1.类名要用Main;
2.BigDecimal的用法;
3.Scanner的用法;
4.二分求高精度根号5
####Code:

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        BigDecimal TWO = BigDecimal.valueOf(2);
        BigDecimal FIVE= BigDecimal.valueOf(5);
        BigDecimal EPS = new BigDecimal(
"-0.0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001");
        BigDecimal l = new BigDecimal("2.2360679774997");
        BigDecimal r = new BigDecimal("2.2360679774998");
        BigDecimal mid=null;

        //二分求sqrt(5)
        while (l.subtract(r).compareTo(EPS) < 0) {
            mid = l.add(r).divide(TWO);//mid = (l+r)>>1;
            if (mid.multiply(mid).subtract(FIVE).abs().compareTo(EPS.abs()) < 0) break;
            if (mid.multiply(mid).subtract(FIVE).compareTo(EPS) < 0) l = mid;
            else r = mid;
        }

        BigDecimal GOLD = mid.add(BigDecimal.ONE).divide(TWO);
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext()) {
            BigDecimal a = sc.nextBigDecimal();
            BigDecimal b = sc.nextBigDecimal();
            if(a.compareTo(b)>0){
                BigDecimal t=a;a=b;b=t;
            }
            BigDecimal c=b.subtract(a).setScale(0,BigDecimal.ROUND_FLOOR).multiply(GOLD);
            c=c.setScale(0,BigDecimal.ROUND_FLOOR);
            if(a.equals(c)) System.out.println("0");
            else System.out.println("1");
        }
    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值