poj 1068 Parencodings

模拟的题型,基本难度不大,关键读懂题意:
对于给出的原括号串,存在两种数字密码串:
1.p序列:当出现匹配括号对时,从该括号对的右括号开始往左数,直到最前面的左括号数,就是pi的值。
2.w序列:当出现匹配括号对时,包含在该括号对中的所有右括号数(包括该括号对),就是wi的值。
题目的要求:对给出的p数字串,求出对应的s串。
串长限制均为20

提示:在处理括号序列时可以使用一个小技巧,把括号序列转化为01序列,左0右1,处理时比较方便

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

#include<stdio.h>
#include<string.h>
int main()
{
    int t,m,n,i,j,k;
    int a[40],b[40],c[40];
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            memset(b,0,sizeof(b));
            scanf("%d",&m);
            a[0]=0;
            c[0]=0;
            k=1;
            for(i=1; i<=m; i++)
            {
                scanf("%d",&a[i]);
                c[i]=a[i];
                for(j=1; j<=a[i]-a[i-1]; j++)
                {
                    b[k++]=0;
                }
                b[k++]=1;
                c[i]=c[i-1]+j;
            }
            for(i=1; i<=m; i++)
            {
                for(j=c[i]-1; j>=0; j--)
                {
                    if(b[j]==0)
                    {
                        b[c[i]]++;
                        b[j]=1;
                        break;
                    }
                    else
                        b[c[i]]++;
                }
                b[c[i]]--;
            }
             for(i=1; i<=m; i++)
                printf("%d ",(b[c[i]]+1)/2);
            printf("\n");
        }
    }
    return 0;
}
这道题目竟然没调试一遍AC,主要步骤是先把运来的图像模拟出来然后找就行

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值