foj1001 使用了位图

Problem 1001 Duplicate Pair

Accept:3561    Submit:16898
Time Limit: 1000mSec    MemoryLimit : 65536 KB

foj <wbr> <wbr> <wbr>1001 <wbr> <wbr>使用了位图,需要将数组初始化为0值 ProblemDescription

An array of length n, with address from 1 to n inclusive,contains entries from the set {1,2,...,n-1} and there's exactly twoelements with the same value. Your task is to find out thevalue.

foj <wbr> <wbr> <wbr>1001 <wbr> <wbr>使用了位图,需要将数组初始化为0值Input

Input contains several cases.
Each case includes a number n(1<n<=10^6), which is followed by nintegers.
The input is ended up with the end of file.

foj <wbr> <wbr> <wbr>1001 <wbr> <wbr>使用了位图,需要将数组初始化为0值Output

Your must output the value for each case, one perline.

foj <wbr> <wbr> <wbr>1001 <wbr> <wbr>使用了位图,需要将数组初始化为0值 SampleInput

2 1 1 4 1 2 3 2

foj <wbr> <wbr> <wbr>1001 <wbr> <wbr>使用了位图,需要将数组初始化为0值 SampleOutput

1 2

位图数据结构的妙用,对处理大量数据问题效率更高~

Language: Visual C++
Length: 373 Bytes.
Result: Accepted

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
#define  N 1000005
char a[N];
int main()
{
      intn,i,j;
      while(scanf("%d",&n)!=EOF)
      {
            memset(a,0,n);
            for(i=0;i<n;i++)
            {
                    scanf("%d",&j);
            if(a[j]==0)
                        a[j]=1;
            else
              printf("%d\n",j);
            }
      }
            return0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值