poj 2282 The Counting Problem

The Counting Problem
Time Limit: 3000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

[Submit]   [Go Back]   [Status]

Description

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be 
1024 1025 1026 1027 1028 1029 1030 1031 1032

there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.

Input

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.

Output

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.

Sample Input

1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0

Sample Output

1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247

[Submit]   [Go Back]   [Status]

题意:

统计从a数到b中,数过的数里面各个位置上0-9的个数。

分析:

从这道题上更体现了数学的魅力。。。

先不论哪个方法,都是找一个f(n),统计从1数到n的情况,然后再f(b)-f(a-1)出结果。

    递归的话就是建立f(k)和f(10*k+x)的关系,也就是说对于一个大数,先处理到末尾为0,然后再认为是从0开始10个10个数数到这个数。例如,f(2984)就先从2981数到2984(2,9,8各出现4次,1,2,3,4一次)然后

f(2980)可以和f(298)建立递推(实际的时候用f(297)更好一点)。注意这里需要建立一个“乘子”,一开始为1,每次递推一层就*10,然后累加到0-9的记录上。

    直接找的话是这样的,由于这个数n已经确定,所以在第i位上数字j出现的次数可以算出来,它是由第i位前面的数字f和后面的数字t决定的(f要乘以10的i-1次方,而不是i次方,因为相当于你把第i位去掉)。要考虑几个细节:数字j和n在第i位数字的大小比较;0的特殊性(首位不数);第一位和最后一位单独讨论(当数字只有一位的时候也要单独一下)。

呵呵,没啥说的 。我整理的模版:

Source Code

Problem: D   User: sdau_09_zys
Memory: 164 KB   Time: 16 MS
Language: C++   Result: Accepted
Public:  

#include <iostream>
#include <string>
using namespace std;

int a,b;
int ansa[10],ansb[10];

void count_digits(int s,int ans[],int times=1)//
{
    int i,d,p;
    if (s <= 0)return ;
    d = s % 10;
    p = s / 10;
    for (i = 1;i <= d;i ++)ans[i] += times;
    while(p > 0)
    {
        ans[p % 10] += (d + 1) * times;
        p = p / 10;
    }

    for (i = 0;i <= 9;i ++)ans[i] += times * (s / 10);

    times *= 10;
    count_digits((s / 10)-1,ans,times);
    return ;
}


int main()
{
    int i,j;
while(scanf("%d%d",&a,&b) != EOF && a + b > 0)
{
   memset(ansb,0,sizeof(ansb));
   memset(ansa,0,sizeof(ansa));
   if (a >= b)
   {
      swap(a,b);
   }
   a --;
   if (b > a)
   {
      count_digits(b,ansb);
      count_digits(a,ansa);
   }
   for(i=0;i<10;i++)
   {
       printf("%d%c",ansb[i]-ansa[i],i==9?'\n':' ');
   }
    
}

return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值