[POJ] 2282 -> The Counting Problem

The Counting Problem
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 3606 Accepted: 1922

Description

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be
1024 1025 1026 1027 1028 1029 1030 1031 1032

there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.

Input

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.

Output

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.

Sample Input

1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0

Sample Output

1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247
 
解题思路:
只要能快速算出0~n中各个数的出现次数就能解决问题了。 
要把数拆开来看,比如3456=3000+400+50+6。 
然后就只要考虑后面都是0的数就行了。 
0~3000中,我们要分为两部分来考虑: 
在第一位中,0\1\2都出现了1000次。 
假设不管第一位,后面那些位数出现0~9的几率是均等的(先不考虑前导0)。那么就是0\1\2分别作为第一位,后面0~9出现的次数遍都能知道了。 
但是这样并不能直接去算后面的问题,因为第一位为3也出现了一些次数,也要算上去。 
各个位都能这样考虑。
 
Code:
#include <iostream>
using namespace std;

void setCount(int arr[10], char* num){
	int len = strlen(num);
	int n = atoi(num);
	memset(arr, 0, 10 * sizeof(int));
	int k = 1;
	for (int i = 1; i < len; i++){
		k *= 10;
		arr[0] -= k;
	}
	for (int i = 0; i < len; ++i, k /= 10){
		int c = num[i] - '0';
		for (int j = 0; j < c; ++j) arr[j] += k;
		for (int t = 0; t < 10; ++t)
			arr[t] += (len - 1 - i) * c * k / 10;
		if (i + 1 < n)
			arr[c] += atoi(num + 1 + i);
		++arr[c];
		
	}
}

int main()
{
	int x, y;
	char a[16], b[16];
	int t1[10], t2[10];
	while (cin >> x >> y, x || y){
		if (x < y){
			sprintf_s(a, "%d", x-1);
			sprintf_s(b, "%d", y);
		} else {
			sprintf_s(a, "%d", y-1);
			sprintf_s(b, "%d", x);
		}
		setCount(t1, a);
		setCount(t2, b);
		for (int i = 0; i < 10; i++){
			cout << t2[i] - t1[i] << " ";
		}
		cout << endl;
	}

	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值