数据结构 无全图单源最短路径算法

6-11 Shortest Path [1] (25 point(s))

Write a program to find the unweighted shortest distances from any vertex to a given source vertex in a digraph.

Format of functions:

void ShortestDist( LGraph Graph, int dist[], Vertex S );

where LGraph is defined as the following:

typedef struct AdjVNode *PtrToAdjVNode; 
struct AdjVNode{
    Vertex AdjV;
    PtrToAdjVNode Next;
};

typedef struct Vnode{
    PtrToAdjVNode FirstEdge;
} AdjList[MaxVertexNum];

typedef struct GNode *PtrToGNode;
struct GNode{  
    int Nv;
    int Ne;
    AdjList G;
};
typedef PtrToGNode LGraph;

The shortest distance from V to the source S is supposed to be stored in dist[V]. If V cannot be reached from S, store -1 instead.

Sample program of judge:

#include <stdio.h>
#include <stdlib.h>

typedef enum {false, true} bool;
#define MaxVertexNum 10  /* maximum number of vertices */
typedef int Vertex;      /* vertices are numbered from 0 to MaxVertexNum-1 */

typedef struct AdjVNode *PtrToAdjVNode; 
struct AdjVNode{
    Vertex AdjV;
    PtrToAdjVNode Next;
};

typedef struct Vnode{
    PtrToAdjVNode FirstEdge;
} AdjList[MaxVertexNum];

typedef struct GNode *PtrToGNode;
struct GNode{  
    int Nv;
    int Ne;
    AdjList G;
};
typedef PtrToGNode LGraph;

LGraph ReadG(); /* details omitted */

void ShortestDist( LGraph Graph, int dist[], Vertex S );

int main()
{
    int dist[MaxVertexNum];
    Vertex S, V;
    LGraph G = ReadG();

    scanf("%d", &S);
    ShortestDist( G, dist, S );

    for ( V=0; V<G->Nv; V++ )
        printf("%d ", dist[V]);

    return 0;
}

/* Your function will be put here */

Sample Input (for the graph shown in the figure):

7 9
0 1
0 5
0 6
5 3
2 1
2 6
6 4
4 5
6 5
2

Sample Output:

-1 1 0 3 2 2 1 

 

 这个从原点开始进行广度优先搜索算法就行了,首先用一个数组dist[]保存所有点的最小路径,开始将数组都初始化为-1,原点的值设为0,然后进行广度优先搜索算法,每次dist[V] = dist[V_pre]+1即可

#include <stdio.h>
#include <stdlib.h>

// typedef enum { false, true } bool;
#define MaxVertexNum 10  /* maximum number of vertices */
typedef int Vertex;      /* vertices are numbered from 0 to MaxVertexNum-1 */

typedef struct AdjVNode *PtrToAdjVNode;
struct AdjVNode {
	Vertex AdjV;
	PtrToAdjVNode Next;
};

typedef struct Vnode {
	PtrToAdjVNode FirstEdge;
} AdjList[MaxVertexNum];

typedef struct GNode *PtrToGNode;
struct GNode {
	int Nv;
	int Ne;
	AdjList G;
};
typedef PtrToGNode LGraph;

LGraph ReadG(); /* details omitted */

void ShortestDist(LGraph Graph, int dist[], Vertex S);

int main()
{
	int dist[MaxVertexNum];
	Vertex S, V;
	LGraph G = ReadG();

	scanf("%d", &S);
	ShortestDist(G, dist, S);

	for (V = 0; V<G->Nv; V++)
		printf("%d ", dist[V]);

	return 0;
}

/* Your function will be put here */
void ShortestDist(LGraph Graph, int dist[], Vertex S)
{
	Vertex Q[MaxVertexNum];
	Vertex V;
	PtrToAdjVNode W;
	int front = 0, rear = 0;
	for (int i = 0; i < Graph->Nv; i++)
	{
		if (i == S)
			dist[i] = 0;
		else
			dist[i] = -1;
	}

	Q[rear++] = S;
	while (front != rear)
	{
		V = Q[front++];
		for (W = Graph->G[V].FirstEdge; W; W = W->Next)
		{
			if (dist[W->AdjV] == -1)
			{
				dist[W->AdjV] = dist[V] + 1;
				Q[rear++] = W->AdjV;
			}
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值