最短路径问题广度优先搜索练习

Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 124627 Accepted: 38800

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

题目的意思,人的位置在5,牛的位置在7,人有三种移动方式X-1,X+1,2*X

将一维坐标看成顶点,一步移动可到达的点相连通,寻找最短路径就是广度优先搜索。这里需要记录到所有点的路径,所以用以一个结构体来保存,代码

#include<iostream>
#include<cstring>
#include<queue>
#define MAXN 100000
using namespace std;

int visited[MAXN+10];
int N, K;   // 人的坐标为N,牛的坐标为K
struct Step
{
	int x;       // 位置
	int steps;   // 到达x所需的步数
	Step(int xx,int s):x(xx),steps(s){}
};
void BFS();
queue<Step> q;

int main()
{
	cin >> N >> K;
	BFS();
}

void BFS()
{
	memset(visited, 0, sizeof(visited));  // 初始化所有点为未访问
	q.push(Step(N,0));                    // 将当前点的坐标加入队列
	visited[N] = 1;
	while (!q.empty())
	{
		Step s = q.front();
		if (s.x == K)
		{
			cout << s.steps << endl;       // 如果找到当前结点
			return;
		}
		else
		{
			if(s.x-1>=0 && !visited[s.x-1])
			{
				q.push(Step(s.x - 1, s.steps + 1));
				visited[s.x - 1] = 1;
			}

			if (s.x+1<=MAXN && !visited[s.x+1])
			{
				q.push(Step(s.x+1,s.steps+1)); 
				visited[s.x + 1] = 1;
			}

			if (s.x * 2 <= MAXN && !visited[s.x * 2])
			{
				q.push(Step(2 * s.x, s.steps + 1));
				visited[s.x * 2] = 1;
			}
		
			q.pop();
		}
		

	
	}
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值