数据结构 有权图单源最短路径算法Dijkstra练习

6-12 Shortest Path [2] (25 point(s))

Write a program to find the weighted shortest distances from any vertex to a given source vertex in a digraph. It is guaranteed that all the weights are positive.

Format of functions:

void ShortestDist( MGraph Graph, int dist[], Vertex S );

where MGraph is defined as the following:

typedef struct GNode *PtrToGNode;
struct GNode{
    int Nv;
    int Ne;
    WeightType G[MaxVertexNum][MaxVertexNum];
};
typedef PtrToGNode MGraph;

The shortest distance from V to the source S is supposed to be stored in dist[V]. If V cannot be reached from S, store -1 instead.

Sample program of judge:

#include <stdio.h>
#include <stdlib.h>

typedef enum {false, true} bool;
#define INFINITY 1000000
#define MaxVertexNum 10  /* maximum number of vertices */
typedef int Vertex;      /* vertices are numbered from 0 to MaxVertexNum-1 */
typedef int WeightType;

typedef struct GNode *PtrToGNode;
struct GNode{
    int Nv;
    int Ne;
    WeightType G[MaxVertexNum][MaxVertexNum];
};
typedef PtrToGNode MGraph;

MGraph ReadG(); /* details omitted */

void ShortestDist( MGraph Graph, int dist[], Vertex S );

int main()
{
    int dist[MaxVertexNum];
    Vertex S, V;
    MGraph G = ReadG();

    scanf("%d", &S);
    ShortestDist( G, dist, S );

    for ( V=0; V<G->Nv; V++ )
        printf("%d ", dist[V]);

    return 0;
}

/* Your function will be put here */

Sample Input (for the graph shown in the figure):

7 9
0 1 1
0 5 1
0 6 1
5 3 1
2 1 2
2 6 3
6 4 4
4 5 5
6 5 12
2

Sample Output:

-1 2 0 13 7 12 3 

 

 

#include <stdio.h>
#include <stdlib.h>

//typedef enum { false, true } bool;
#define INFINITY 1000000
#define MaxVertexNum 10  /* maximum number of vertices */
typedef int Vertex;      /* vertices are numbered from 0 to MaxVertexNum-1 */
typedef int WeightType;

typedef struct GNode *PtrToGNode;
struct GNode {
	int Nv;
	int Ne;
	WeightType G[MaxVertexNum][MaxVertexNum];
};
typedef PtrToGNode MGraph;

MGraph ReadG(); /* details omitted */

void ShortestDist(MGraph Graph, int dist[], Vertex S);

int main()
{
	int dist[MaxVertexNum];
	Vertex S, V;
	MGraph G = ReadG();

	scanf("%d", &S);
	ShortestDist(G, dist, S);

	for (V = 0; V<G->Nv; V++)
		printf("%d ", dist[V]);

	return 0;
}

/* Your function will be put here */
void ShortestDist(MGraph Graph, int dist[], Vertex S)
{
	// dist[i] 表示 S到i的距离
	for (int i = 0; i < Graph->Nv; i++)
	{
		dist[i] = Graph->G[S][i];
	}
	int visited[MaxVertexNum] = { 0 };  // 记录各个点是否被访问过
	visited[S] = 1;                     // 标记原点
	for (int i = 0; i < Graph->Nv; i++)
	{
		int min = INFINITY;             // 最小距离
		int t = INFINITY;               // t记录最小距离的点
		for (int j = 0; j < Graph->Nv; j++)
		{
			if (!visited[j] && dist[j] < min)
			{
				min = dist[j];
				t = j;
			}
		}
		if (min == INFINITY)
			continue;                   // 如果当前无最小距离

		visited[t] = 1;                 // 标记选出来的点

		for (int j = 0; j < Graph->Nv; j++)
		{
			if (!visited[j])
			{
				if (dist[j] > Graph->G[t][j] + min)
				{
					dist[j] = Graph->G[t][j] + min;
				}
			}
		}

	}

	// 处理原点和没有连接点的数据输出
	for (int i = 0; i < Graph->Nv; i++)
	{
		if (i == S)
			dist[i] = 0;
		else if (dist[i] == INFINITY)
			dist[i] = -1;

	}
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值