Aggressive cows(最大化最小值问题)

点击打开链接

Problem Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
 

Input
* Line 1: Two space-separated integers: N and C< br>< br>* Lines 2..N+1: Line i+1 contains an integer stall location, xi
 

Output
* Line 1: One integer: the largest minimum distance
 

Sample Input
  
  
5 3 1 2 8 4 9
 

Sample Output
  
  
3
 

题目大意:

//有n个点,给出每个点的位置,然后没c个点一组,这一组里的距离的最小值为minn,在若干个这样的组合中求出各个minn值中的最大值

思路:

将位置排排序,在最小距离和最大的距离中间,进行二分,看看能放的牛的牛棚的个数,和牛的数量比较,然后改变二分的区间。




#if 0
#include<iostream>
#include<cmath>  
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
int a[100005];
int n,c;
int fun(int mid)
{
	int cnt=1,sum=0;
	for(int i=1; i<n; i++)
	{
		if(sum+a[i]-a[i-1]<mid)
		{
			sum+=a[i]-a[i-1];
		}
		else
		{
			sum=0;
			cnt++;	
		}	
	}
	
	if(cnt>=c)
	{
		return 1;	
	}
	else
	{
		return 0;	
	}	
}

int main()
{
	
	while(scanf("%d%d",&n,&c)==2)
	{
		memset(a,0,sizeof(a));
		for(int i=0; i<n; i++)
		{
			scanf("%d",&a[i]);
		}
		
		sort(a,a+n);
		int r=a[n-1]-a[0],l=a[n-1]-a[0];
		
		for(int i=1; i<n; i++)
		{
			if(a[i]-a[i-1]<l)
				l=a[i]-a[i-1];
		}
		
		while(r>=l) 
		{
			int mid=(l+r)/2;     
			if(fun(mid))            //多了 
			{
				l=mid+1;
			}
			else
			{
				r=mid-1;
			}
		}
		
		printf("%d\n",r);
	
	}
}
#endif





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值