Monthly Expense

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers:  N and  M 
Lines 2..  N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

今天精神却是不是很旺盛,晚上讲知识点都是打着哈欠过去的,所以这道题实在是想不出怎么做了,所以看了下大神的代码,瞬间明白原理是啥,明白之后发现这道挺简单的,就是一些做题技巧不是很会,所以导致不明白怎么做,还是刷的题少0.0,话不多说,代码如下,代码还是挺简单的,所以也就不解释了:

#include <iostream>  
#include <cstdio>  
#include <algorithm>  
using namespace std;  
int n,m;  
int a[100005],l,r,sum,mid;
bool cal(int b)
{  int s=0;
  int cns=1;
    for(int i=0;i<n;i++)
    {
    	if(s+a[i]<=b)
    	s=s+a[i];
    	else
    	{
    		cns++;
    		s=a[i];
		}
		if(cns>m)
		return 0;
	}
	if(cns<=m)
	return 1;
  }  
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{   l=sum=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			l=max(l,a[i]);
			sum=sum+a[i];
		}
		r=sum;
		while(r>=l)
		{
			mid=(r+l)/2;
			if(cal(mid))
			r=mid-1;
			else
			l=mid+1;
		}
		printf("%d\n",mid);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值