杭电 【1003】 Max Sum


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L

一道动态规划题,求出最大的子序列的和,代码如下,代码有详解

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int T;//T组数据 
	int n;//n个数字 
	int k;//每次输入的数据 
	int x;//实时更新的开始位置 
	int now,max;//now表示的当前得到的和,max表示的是目前得到的最大和; 
	int post1,post2;//起始位置 和 末位置 
	scanf("%d",&T);
	int h=T;//Case 后面的数字需要用到这个数据 
	while(T--)
	{   
		scanf("%d",&n);
        scanf("%d",&k);
		now=max=k;//初始化now和max 
		post1=post2=x=1;//初始化位置信息 
		for(int i=2;i<=n;i++)
		{
			scanf("%d",&k);
			if(k>now+k)//如果目前输入的数据比前面的数据加上本身还大的话 从新开始记录和 
			{
				now=k,x=i;//x表示更新初始位置 
			}
			else//否则的话继续更新目前得到的和的大小 
			now=now+k;
			if(now>max)//如果目前得到的和大于前面统计的最大和的话更新此时的最大和,同时更新初始位置,末位置就是此时输入数据的下标 
			max=now,post1=x,post2=i;
		}
		printf("Case %d:\n",h-T);
		printf("%d %d %d\n",max,post1,post2);
		if(T!=0)//如果不是最后一组数据  则在结果后面再输入一行空行 
		printf("\n");  
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值