PAT 1145 Hashing - Average Search Time (25 分)

1145 Hashing - Average Search Time (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

题意: ms,n,m,ms为哈希表长度,若ms不为素数,取大于ms最近的素数为哈希表长度(哈希表冲突处理要求使用二次探测),n个需要插入的数,若不能插入,输出“cannot be inserted”,m个需要查询的数,输出平均查询时间,精确到小数点后1位。

解题感悟:做这道题最重要的是要读懂题意,我在刚开始做的时候,就把对哈希表长度的要求给漏掉了,以至于我在理解题意的时候百思不得其解,甚至都怀疑题目的质量(我自认英语水平还不错)。直到后来从网上找了一下,看了下别人对题目的解读,我再重新读了题目才明白是怎么回事,所以说,读题非常重要。这道题我并没有得满分,只得了22分,提示浮点错误。

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
using namespace std;
int p[100000]= {0};
int  fun(int n)
{
    if(n<=1) return 0;
    int sqr=(int)sqrt(1.0*n);
    for(int i=2; i<=sqr; i++)
    {
        if(n%i==0)
            return 0;
    }
    return 1;
}
int main()
{
    int s,n,m,i,j,k,a;
    scanf("%d %d %d",&s,&n,&m);
    if(fun(s)==0)
    {
        k=s;
        while(1!=0)
        {

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值