PAT甲级 1037

1037 Magic Coupon (25 分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output: 

43

 题意:有n种优惠券和m种商品,若优惠券是正数,商品的价格也是正数,则可以得到两者乘积的金钱;换言之只要 优惠券与商品的乘积是正数,则消费者可以得到成绩大小的金钱,否则,消费者就要向商家支付优惠券与商品乘积绝对值的金钱,问消费者最终能得到的最大金额。

总结:将优惠券、商品价格分别进行从小到大的排序,从前往后 进行负数的乘积相加,从后往前进行正数的乘积相加,即能得出最大金额。

#include<iostream>
#include<bits/stdc++.h>
#define long 100001
using namespace std;
int a[100005],b[100005];
int main()
{
    int n1;
    cin>>n1;
    for(int i=0;i<n1;i++)
    {
        cin>>a[i];
    }
    sort(a,a+n1);
    int n2;
    cin>>n2;
    for(int j=0;j<n2;j++)
    {
        cin>>b[j];
    }
    sort(b,b+n2);
    int ans=0;
    int it1=0;
    int it2=0;
    while(it1<n1&&it2<n2)
    {
        if(a[it1]<0&&b[it2]<0)
        {
            ans+=a[it1]*b[it2];
            it1++;
            it2++;
        }
        else
        {
            break;
        }
    }
    it1=n1-1;
    it2=n2-1;
    while(it1>=0&&it2>=0)
    {
        if(a[it1]>0&&b[it2]>0)
        {
            ans+=a[it1]*b[it2];
            it1--;
            it2--;
        }
        else
        {
            break;
        }
    }
    cout<<ans<<endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值