【PAT】1031 Hello World for U 解题报告

1031 Hello World for U (20分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题解

#include <stdio.h>
#include <string.h>
#define Max 81
int main()
{
    char str[Max];
    gets(str);
    int len = strlen(str);//字符串长度
    int n1, n2, n3;
    int i, j; 
    n1 = n3 = (len + 2) / 3;
    n2 = (len + 2 ) / 3 + (len + 2) % 3;
    for(i = 0; i < n1 - 1; i++){
        printf("%c", str[i]);
        for(j = 0; j < n2 - 2; j++){
        	printf(" ");
		}
        printf("%c\n", str[len - 1 - i]);
    }
    for(; i < n1 + n2 - 1; i++){
    	printf("%c", str[i]);//最后一行
	}
    printf("\n");
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值