《算法笔记》5.4小节——数学问题->素数

这篇博客介绍了三个与素数相关的问题:寻找个位为1的素数、输出第k个素数以及Goldbach's Conjecture的编程实现。对于每个问题,博客提供了题目描述、输入输出格式、样例以及解题思路。
摘要由CSDN通过智能技术生成

目录

问题 A: 素数

问题 B: Prime Number

问题 C: Goldbach's Conjecture


问题 A: 素数

题目描述

输入一个整数n(2<=n<=10000),要求输出所有从1到这个整数之间(不包括1和这个整数)个位为1的素数,如果没有则输出-1。

输入

输入有多组数据。
每组一行,输入n。

输出

输出所有从1到这个整数之间(不包括1和这个整数)个位为1的素数(素数之间用空格隔开,最后一个素数后面没有空格),如果没有则输出-1。

样例输入

70

样例输出

11 31 41 61

题解

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 10010;
int prime[maxn], num = 0;
bool p[maxn] = {0};
void Find_Prime(){//素数筛法 
	int i, j;
	for(i = 2; i < maxn; i++){
		if(p[i] == false){//没有被筛去 
			prime[num++] = i;
			for(j = i + i; j < maxn; j = j + i){//筛去所有i的倍数 
				p[j] = true;
			}
		}
	}
} 
int main(){
	int n;
	Find_Prime();
	while(scanf("%d", &n) != EOF){
		int ans[maxn] = {0};
		int cnt = 0;
		int i;
        for(i = 2; prime[i] < n; i++){
            if(prime[i] % 10 == 1){
            	ans[cnt++] = prime[i];
			}
        }
        if(cnt == 0){
        	printf("-1\n");
		}
        else{
            for(i = 0; i < cnt; i++){
                printf("%d", ans[i]);
                if(i < cnt - 1){
                	printf(" ");
				}
                else{
                	printf("\n");
				}  
            }
        }
	}
    return 0;
}

问题 B: Prime Number

题目描述

Output the k-th prime number.

输入

k≤10000

输出

The k-th prime number.

样例输入

10
50

样例输出

29
229

题解

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1000001;
int prime[maxn], num = 0;
bool p[maxn] = {0};
void Find_Prime(){//素数筛法
	int i, j;
	for(i = 2; i < maxn; i++){
		if(p[i] == false){//没有被筛去
			prime[num++] = i;
			for(j = i + i; j < maxn; j = j + i){//筛去所有i的倍数
				p[j] = true;
			}
		}
	}
} 
int main(){
	int k;
	Find_Prime();
	while(scanf("%d", &k) != EOF){
		printf("%d\n", prime[k - 1]);
	}
    return 0;
}

问题 C: Goldbach's Conjecture

题目描述

Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

输入

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

输出

Each output line should contain an integer number. No other characters should appear in the output.

样例输入

4
10
16
0

样例输出

1
2
2

题解

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1000001;
int prime[maxn], num = 0;
bool p[maxn] = {0};
void Find_Prime(){//素数筛法
	int i, j;
	for(i = 2; i < maxn; i++){
		if(p[i] == false){//没有被筛去
			prime[num++] = i;
			for(j = i + i; j < maxn; j = j + i){//筛去所有i的倍数
				p[j] = true;
			}
		}
	}
} 
int main(){
	int n;
	Find_Prime();
	while(scanf("%d", &n) != EOF){
		if(n == 0){
			break;
		}
		int i, j;
		int ans = 0;
		for(i = 0; prime[i] < n; i++){
			for(j = i; prime[j] < n; j++){
				if(prime[i] + prime[j] == n){
					ans++;
				}
				if(prime[i] + prime[j] > n){
					break;
				}
			}
		}
		printf("%d\n", ans);
	}
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值