九度OJ 1201 二叉排序树

题目描述:

    输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。

输入:

    输入第一行包括一个整数n(1<=n<=100)。
    接下来的一行包括n个整数。

输出:

    可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。
    每种遍历结果输出一行。每行最后一个数据之后有一个空格。

样例输入:
5
1 6 5 9 8
样例输出:
1 6 5 9 8 
1 5 6 8 9 
5 8 9 6 1 
提示:

输入中可能有重复元素,但是输出的二叉树遍历序列中重复元素不用输出。

来源:
2005年华中科技大学计算机保研机试真题
#include <stdio.h>
#include <stdlib.h>

typedef struct btree{
 int data;
 struct btree *lchild;
 struct btree *rchild;
}Btree;

void insert(Btree *&a,int k)
{
  if(a == NULL)
  {
   a = (Btree *)malloc(sizeof(Btree));
   a->data = k;
   a->lchild = NULL;
   a->rchild = NULL;
   // printf("%d",a->data);
  }
  else if(k < a->data)
  {
   insert(a->lchild,k);
  // printf("%d",a->data);
  }
  else if(k > a->data)
  {
   insert(a->rchild,k);
   // printf("%d",a->data);
  }
}

void q(Btree *a)
{
 if(a!=NULL)
  {
  printf("%d ",a->data);
   q(a->lchild);
   q(a->rchild);
  }
}

void w(Btree *a)
{
 if(a!=NULL)
  {
 
   w(a->lchild);
   printf("%d ",a->data);
   w(a->rchild);
  }
}

void e(Btree *a)
{
 if(a!=NULL)
  {
 
   e(a->lchild);
   e(a->rchild);
   printf("%d ",a->data);
  }
}

int main()
{
int n;
while(scanf("%d",&n) != EOF)
{
  Btree *a = NULL;
  int tree[100];
  for(int i=0;i<n;i++)
  scanf("%d",&tree[i]);
  
 
   for(int i=0;i<n;i++)
   insert(a,tree[i]);
 
    q(a);
  printf("\n");
   w(a);
  printf("\n");
  e(a);
  printf("\n");

 
 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值