【杭电oj】1787 - GCD Again(欧拉函数)

GCD Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2762    Accepted Submission(s): 1176


Problem Description
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem: 
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!
 

Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
 

Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input. 
 

Sample Input
  
  
2 4 0
 

Sample Output
  
  
0 1
 

Author
lcy
 

Source


这次做欧拉函数的题,忘了好多了,得加强记忆一下了。

代码如下:

#include <cstdio>
#include <cmath>
int Eular(int n)
{
	int ans=1;
	double t = (double)n;
	for (int i=2;i<=sqrt(t);i++)
	{
		if (n%i==0)
		{
			n/=i;
			ans*=(i-1);
			//若n有个因子是i的k次,根据欧拉公式有下面的代码
			while (n%i==0) 
			{
				n/=i;
				ans*=i;
			}
		}
	}
	if (n>1)		//若最后剩的数为大于5的素数,根据欧拉公式再算进去 
		ans*=(n-1);
	return ans;
}
int main()
{
	int n;
	int ans;
	while (~scanf ("%d",&n) && n)
	{
		ans = Eular (n);
		ans = n - 1 - ans;		//去除与其互质的数,剩下的就是GCD(N,M)> 1 的数了
		printf ("%d\n",ans); 
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值