【POJ】3468 - A Simple Problem with Integers(线段树区间更新)

题目链接:点击打开链接

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 100877 Accepted: 31450
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source




线段树区间更新的模板题。

代码如下:

#include <cstdio>
#include <stack>
#include <queue>
#include <cmath>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
#define LL long long
#define MAX 100000
#define L o<<1
#define R o<<1|1
struct node
{
	int l,r;
	LL sum;
	LL lazy;
	int length;		//延迟标记,区间长度 
}Tree[MAX<<2];

void PushUp(int o)
{
	Tree[o].sum = Tree[L].sum + Tree[R].sum;
}

void Build(int o,int l,int r)
{
	Tree[o].l = l;
	Tree[o].r = r;
	Tree[o].lazy = 0;
	Tree[o].length = r - l + 1;
	if (l == r)
	{
		scanf ("%lld",&Tree[o].sum);
		return;
	}
	int mid = (l + r) >> 1;
	Build(L,l,mid);
	Build(R,mid+1,r);
	PushUp(o);
}

void PushDown(int o)
{
	if (Tree[o].lazy)
	{
		Tree[L].sum = Tree[L].sum + Tree[o].lazy * Tree[L].length;
		Tree[R].sum = Tree[R].sum + Tree[o].lazy * Tree[R].length;
		Tree[L].lazy += Tree[o].lazy;
		Tree[R].lazy += Tree[o].lazy;
		Tree[o].lazy = 0;
	}
}

void UpDate(int o,int l,int r,int lazy)
{
	if (Tree[o].l == l && Tree[o].r == r)
	{
		Tree[o].sum += Tree[o].length * lazy;
		Tree[o].lazy += lazy;
		return;
	}
	PushDown(o);
	int mid = (Tree[o].l + Tree[o].r) >> 1;
	if (mid >= r)
		UpDate(L,l,r,lazy);
	else if (l > mid)
		UpDate(R,l,r,lazy);
	else
	{
		UpDate(L,l,mid,lazy);
		UpDate(R,mid+1,r,lazy);
	}
	PushUp(o);
}

LL Query(int o,int l,int r)
{
	if (Tree[o].l == l && Tree[o].r == r)
		return Tree[o].sum;
	PushDown(o);
	int mid = (Tree[o].l + Tree[o].r) >> 1;
	if (mid >= r)
		return Query(L,l,r);
	else if (l > mid)
		return Query(R,l,r);
	else
	{
		return (Query(L,l,mid) + Query(R,mid+1,r));
	}
}

int main()
{
	int n,m;
	scanf ("%d %d",&n,&m);
	Build(1,1,n);
	int x,y,z;
	char op[3];
	while(m--)
	{
		scanf ("%s",op);
		if (op[0] == 'C')
		{
			scanf ("%d %d %d",&x,&y,&z);
			UpDate(1,x,y,z);
		}
		else
		{
			scanf ("%d %d",&x,&y);
			printf ("%lld\n",Query(1,x,y));
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值