从指定位置删除指定长度的字符串(串)

Problem F: 从指定位置删除指定长度的字符串(串)

 

Description

从一个字符串中的第p个位置起删除指定长度的字符串,输出最终结果,若输入不合法,则输出 Illegal input

Input

输入一个字符串s、位置p、长度n

Output

删除子串后的字符串

Sample Input

adfasdf12
6 5

Sample Output

Illegal input

 

#include<stdio.h>
int main()
{
    int n,m,i,j,t;
    char s[99];
    gets(s);
    t=strlen(s);
    scanf("%d%d",&m,&n);
    if(m+n>t)          //output the error message 
    printf("Illegal input");
    else
    {
        for(i=0;i<m-1;i++) //output the front 
        printf("%c",s[i]);
        for(i=m+n-1;i<t;i++) //output the second
        printf("%c",s[i]);
    }
    return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Loganer

感谢

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值