YTU 2301: 串的基本操作二(串)

2301: 串的基本操作二(串)


Description

输入一定量的单词(#结束),按字母顺序排序后输出,若有重复则只保留一个。

Input

Output

Sample Input

hello
I
how
fine
free
if
free
final
full
all
aware
#

Sample Output

all
aware
final
fine
free
full
hello
how
I
#include<stdio.h>
#include<string.h>
int main()
{
    int i=0,j,k,len,m;
    char s[99][99],tm[99];
    int t;
    while(~scanf("%s",&s[i]))
    {
        if(s[i][0]=='#')
            break;
        if(s[i][0]>='A'&&s[i][0]<='Z')//uppercase judgement
            s[i][0]+=32;
        i++;
    }
    t=i;
    for(i=0;i<t;i++)
    {
        for(j=0;j<t-1-i;j++)
        {
            if(strcmp(s[j],s[j+1])>0) //using the strcmp comparison by order
            {
                strcpy(tm,s[j]);
                strcpy(s[j],s[j+1]);//exchange order
                strcpy(s[j+1],tm);
            }
        }
    }
    for(k=0;k<t;k++)
    {
        if(s[k][0]>='a'&&s[k][0]<='z'&&s[k][1]=='\0')//According to the test data,judge uppercase
        {
            s[k][0]-=32;
        }
        if(strcmp(s[k],s[k+1])!=0)
        {
            printf("%s\n",s[k]);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Loganer

感谢

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值