pat 1008. Elevator (20)

1008. Elevator (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41
解:题目意思看懂就好,给定电梯要上的个数,比如3个,第一个是第二层2,第二个是第三层3,第三个是第一层1,题面说上一层耗时6,下一层耗时4,每一层停留的时间为5.将这些时间以一种合理的方式累加即可,我是先初始化为电梯要上的个数n*5,然后逐个读取进行判断是上楼梯还是下楼梯,再进行累加的。

代码:
#include<iostream>
#include<cmath>
#include<cstdlib>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int num;
    while(scanf("%d",&num)==1)
    {
        int *a=new int[num+1];
        int time=num*5;
        for(int i=0;i<num;i++)
        {
            scanf("%d",&a[i]);
            if(i==0)
                time+=a[i]*6;
            if(i!=0&&a[i]>a[i-1])
            {
                time+=(a[i]-a[i-1])*6;
            }
            if(i!=0&&a[i]<a[i-1])
            {
                time+=(a[i-1]-a[i])*4;
            }
        }
        printf("%d\n",time);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值