For a positive integer N , the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N , we call N a generator of M .
For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.
Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.
You are to write a program to find the smallest generator of the given integer.
Input
Your program is to read from standard input. The input consists of T test cases. The number of test cases Tis given in the first line of the input. Each test case takes one line containing an integer N , 1N100, 000 .
Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print 0.
The following shows sample input and output for three test cases.
Sample Input
3 216 121 2005
Sample Output
198 0 1979
打表存储,从1到100000的生成元。
代码:
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 100000 + 10000;
int a[N];
int sum(int n)
{
int res = 0;
while(n)
{
res += n % 10;
n = n/10;
}
return res;
}
void init()
{
memset(a, 0, sizeof(a));
for(int i = 0; i <= 100000; i++)
{
int tmp = i + sum(i);
if(!a[tmp])
{
a[tmp] = i;
}
}
}
int main()
{
int num, n;
scanf("%d", &num);
init();
for(int i = 1; i <= num; i++)
{
scanf("%d", &n);
printf("%d\n", a[n]);
}
return 0;
}