[POJ] 2379 -> ACM Rank Table

3 篇文章 0 订阅
ACM Rank Table
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4523 Accepted: 1188

Description

ACM contests, like the one you are participating in, are hosted by the special software. That software, among other functions, preforms a job of accepting and evaluating teams' solutions (runs), and displaying results in a rank table. The scoring rules are as follows:
  1. Each run is either accepted or rejected.
  2. The problem is considered solved by the team, if one of the runs submitted for it is accepted.
  3. The time consumed for a solved problem is the time elapsed from the beginning of the contest to the submission of the first accepted run for this problem (in minutes) plus 20 minutes for every other run for this problem before the accepted one. For an unsolved problem consumed time is not computed.
  4. The total time is the sum of the time consumed for each problem solved.
  5. Teams are ranked according to the number of solved problems. Teams that solve the same number of problems are ranked by the least total time.
  6. While the time shown is in minutes, the actual time is measured to the precision of 1 second, and the the seconds are taken into account when ranking teams.
  7. Teams with equal rank according to the above rules must be sorted by increasing team number.

Your task is, given the list of N runs with submission time and result of each run, compute the rank table for C teams.

Input

Input contains integer numbers C N, followed by N quartets of integes ci pi ti ri, where ci -- team number, pi -- problem number, ti -- submission time in seconds, ri -- 1, if the run was accepted, 0 otherwise.
1 ≤ C, N ≤ 1000, 1 ≤ ci ≤ C, 1 ≤ pi ≤ 20, 1 ≤ ti ≤ 36000.

Output

Output must contain C integers -- team numbers sorted by rank.

Sample Input

3 3
1 2 3000 0
1 2 3100 1
2 1 4200 1

Sample Output

2 1 3
 
解题思路:
可能出现以下几个问题:
1.ac了的题目重复提交
2.有可能不按时间顺序排列
3.没k题过的队伍也要算上
4.提交时间和罚时单位一个是秒一个是分钟
 
Code:
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

typedef struct Team{
	int ci;
	int count;
	int time;
	int wrong[21];
	Team() : count(0), time(0) { memset(wrong, 0, 21 * sizeof(int)); }
} Team;

typedef struct Submission{
	int ci, pi, ti;
	bool ri;
	Submission(int c, int p, int t, bool r) : ci(c), pi(p), ti(t), ri(r) {}
}Submission;

bool cmp_subs(Submission& sub1, Submission sub2){
	return sub1.ti < sub2.ti;
}

bool cmp_teams(Team& t1, Team& t2){
	if (t1.count != t2.count)
		return t1.count > t2.count;
	else if (t1.time != t2.time)
		return t1.time < t2.time;
	else return t1.ci < t2.ci;
}

int main()
{
	int C, N, ci, pi, ti;
	bool ri;
	cin >> C >> N;
	Team* teams = new Team[C+1];
	vector<Submission> subs;
	for (int i = 1; i <= C + 1; ++i)
		teams[i].ci = i;
	for (int i = 0; i < N; i++){
		cin >> ci >> pi >> ti >> ri;
		Submission sub(ci, pi, ti, ri);
		subs.push_back(sub);
	}
	sort(subs.begin(), subs.end(), cmp_subs);
	for (vector<Submission>::iterator it = subs.begin(); it != subs.end(); ++it){
		if (teams[it->ci].wrong[it->pi] != -1) { //如果没有提交(有些白痴队伍ac了还要重复提交)
			if (it->ri == true){
				teams[it->ci].time += teams[it->ci].wrong[it->pi] * 20 * 60 + it->ti;
				++teams[it->ci].count;
				teams[it->ci].wrong[it->pi] = -1;
			} else ++teams[it->ci].wrong[it->pi];
		}
	}
	sort(teams + 1, teams + C + 1, cmp_teams);
	for (int i = 1; i < C; i++)
		cout<<teams[i].ci<<" ";
	cout << teams[C].ci << endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值