[POJ] 1458 -> Common Subsequence

2 篇文章 0 订阅
Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 41382 Accepted: 16722

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
 
解题思路:


 
Code:
#include <iostream>  
using namespace std;

#define MAX_SIZE 256
int C[MAX_SIZE][MAX_SIZE];

inline int LCS(const char* str1, const char* str2){
	int len1 = strlen(str1);
	int len2 = strlen(str2);
	for (int i = 0; i < len1; ++i){
		for (int j = 0; j < len2; ++j){
			if (i == 0 || j == 0) C[i][j] = 0;
			else if (str1[i] == str2[j]) C[i][j] = C[i - 1][j - 1] + 1;
			else C[i][j] = (C[i - 1][j] > C[i][j - 1]) ? C[i - 1][j] : C[i][j - 1];
		}
	}
	return C[len1 - 1][len2 - 1];
}

int main(){
	char a[256], b[256];
	while (cin >> a+1 >> b+1)
		cout << LCS(a, b) << endl;
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值