[POJ] 1579 -> Function Run Fun

4 篇文章 0 订阅
Function Run Fun
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16896 Accepted: 8721

Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1
 
递归水题
 
Code:
#include <iostream>  
using namespace std;

#define MAX 21

int main(){
	int arr[MAX][MAX][MAX];
	memset(arr, 0, sizeof(int)* MAX);
	for (int a = 0; a < MAX; ++a){
		for (int b = 0; b < MAX; ++b){
			for (int c = 0; c < MAX; ++c){
				if (a == 0 || b == 0 || c == 0) arr[a][b][c] = 1;
				else if (a < b && b < c) arr[a][b][c] = arr[a][b][c - 1] + arr[a][b - 1][c - 1] - arr[a][b - 1][c];
				else arr[a][b][c] = arr[a - 1][b][c] + arr[a - 1][b - 1][c] + arr[a - 1][b][c - 1] - arr[a - 1][b - 1][c - 1];
			}
		}
	}
	int a, b, c, x, y, z;
	while (cin >> a >> b >> c, a + 1 || b + 1 || c + 1){
		x = a, y = b, z = c;
		if (x < 0 || y < 0 || z < 0){
			x = 0; y = 0; z = 0;
		}
		if (x > 20 || y > 20 || z > 20){
			x = 20; y = 20; z = 20;
		}
		printf("w(%d, %d, %d) = %d\n", a, b, c, arr[x][y][z]);
	}
		
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值