POJ_2377 Bad Cowtractors

Bad Cowtractors
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9195 Accepted: 3939

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42


题意:John的农场之间构成一个网络,他想花费最小代价建造一些路使得每个农场能够连通,但他不想给Bessie支付酬劳。。。Bessie认识到John不会得到酬劳,于是在设计连通这些农场的路时决定把这些路连通所有点花费的代价总和最大化。

思路:图-->树,明显是最小生成树(本题使用Kruskal的最小生成树方法)...但是需要生成树所有权总和最大...构建的时候条件有所修改。具体代码如下:

#include<iostream>
#include<vector>
#include<queue>
#define SIZE 1005
using namespace std;

struct edge
{
	int u;
	int v;
	long cost;

	
};
struct cmp
{
	bool operator () (const edge &a, const edge &b) const
	{
		return a.cost < b.cost;
	}
};

typedef struct edge Edge;

int s[SIZE];


int find(int x)
{
	if(s[x] < 0)
		return x;
	else
		return find(s[x]);
}
void unionSets(int root1, int root2)
{
	s[root2] = root1;
}
int main()
{
	int i,n,m,acedge,vset,uset;
	long sum;
	Edge k;
	priority_queue<Edge,vector<Edge>,cmp> pq;
	cin >> n >> m;
	
	for(i = 1; i <= n; i++)
		s[i] = -1;

	while(m--)
	{
		cin >> k.u >> k.v >> k.cost;
		pq.push(k);
	}

		//test
	/*cout << endl;
	while(pq.empty() != true)
	{
		k = pq.top();
		cout << pq.top().u << " " << pq.top().v << " " << pq.top().cost << endl;
		pq.pop();
	}
	cout << endl;*/

	acedge = 0;
	sum = 0;
	while(pq.empty() != true)
	{
		k = pq.top();
		pq.pop();
		uset = find(k.u);
		vset = find(k.v);

		if(uset != vset)
		{
			acedge++;
			unionSets(uset, vset);
			sum += k.cost;
		}
	}


	
	if(acedge == n - 1)
		cout << sum << endl;
	else
		cout << "-1" << endl;


	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值