A hard puzzle

Problem Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

Output

For each test case, you should output the a^b's last digit number.

Sample Input

7 66
8 800

Sample Output

9
6

 分析:求a^b的最后一位数。找到循环节然后分别对应输出即可。

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;

int main(){
    int a,b;
    while(cin>>a>>b){
        a%=10;
        if(a==0||a==1||a==5||a==6)cout<<a<<endl;
        if(a==2){
            if(b%4==0)cout<<6<<endl;
            if(b%4==1)cout<<2<<endl;
            if(b%4==2)cout<<4<<endl;
            if(b%4==3)cout<<8<<endl;
        }
        if(a==3){
            if(b%4==0)cout<<1<<endl;
            if(b%4==1)cout<<3<<endl;
            if(b%4==2)cout<<9<<endl;
            if(b%4==3)cout<<7<<endl;
        }    
        if(a==4){
            if(b%2==0)cout<<6<<endl;
            if(b%2==1)cout<<4<<endl;
        }
        if(a==7){
            if(b%4==0)cout<<1<<endl;
            if(b%4==1)cout<<7<<endl;
            if(b%4==2)cout<<9<<endl;
            if(b%4==3)cout<<3<<endl;
        }
        if(a==8){
            if(b%4==0)cout<<6<<endl;
            if(b%4==1)cout<<8<<endl;
            if(b%4==2)cout<<4<<endl;
            if(b%4==3)cout<<2<<endl;
        }
        if(a==9){
            if(b%2==0)cout<<1<<endl;
            if(b%2==1)cout<<9<<endl;
        }
        
    }
    return 0;
}

 

单词搜索迷宫(Word Search Puzzle)问题是一个经典的算法问题,其输入是一个二维的字符数组和一组单词,目标是找出字符数组网格中的所有单词。这些单词可以是水平的、垂直的或者是任意的对角线方向,所以需要查找8个不同的方向。解决这个问题的一种常见方法是使用回溯算法,具体步骤如下: 1. 遍历二维字符数组,对于每个字符,以其为起点开始搜索,搜索的方向包括水平、垂直和对角线方向。 2. 对于每个搜索到的单词,将其记录下来。 3. 重复步骤1和2,直到遍历完整个二维字符数组。 下面是一个使用C#语言实现的单词搜索迷宫算法的示例代码: ```csharp class WordSearchPuzzle { private char[,] grid; private HashSet<string> words; public WordSearchPuzzle(char[,] grid, HashSet<string> words) { this.grid = grid; this.words = words; } public void Solve() { int rows = grid.GetLength(0); int cols = grid.GetLength(1); for (int i = 0; i < rows; i++) { for (int j = 0; j < cols; j++) { Search(i, j, new StringBuilder()); } } } private void Search(int row, int col, StringBuilder sb) { if (row < 0 || row >= grid.GetLength(0) || col < 0 || col >= grid.GetLength(1)) { return; } sb.Append(grid[row, col]); string word = sb.ToString(); if (words.Contains(word)) { Console.WriteLine("Found '{0}' at [{1}, {2}] to [{3}, {4}]", word, row, col, row - sb.Length + 1, col - sb.Length + 1); } if (word.Length < 3) { Search(row + 1, col, sb); Search(row - 1, col, sb); Search(row, col + 1, sb); Search(row, col - 1, sb); Search(row + 1, col + 1, sb); Search(row - 1, col - 1, sb); Search(row + 1, col - 1, sb); Search(row - 1, col + 1, sb); } sb.Remove(sb.Length - 1, 1); } } // 使用示例 char[,] grid = new char[,] { {'t', 'h', 'i', 's'}, {'w', 'a', 't', 's'}, {'o', 'a', 'h', 'g'}, {'f', 'g', 'd', 't'} }; HashSet<string> words = new HashSet<string>() { "this", "two", "fat", "that" }; WordSearchPuzzle puzzle = new WordSearchPuzzle(grid, words); puzzle.Solve(); ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值