HDU 2647:Reward

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8557    Accepted Submission(s): 2737

点击打开题目链接
Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 

Sample Output
  
  
1777 -1
AC代码:
#include<iostream>
#include<cstdio>
#include<queue>
#include<vector>
#include<cstring>
#include<stack>
#define INF 0x3f3f3f3f
#define MAXN 10003

using namespace std;

int n,m;         
vector<int>node[MAXN];  ///容器来存放图
int num[MAXN];          ///num[i]用来存放节点i的入度
struct reward
{
    int index;          ///人的编号
    int money;          ///它的钱数
};
int HaveTopSort()       ///判断是否存在环
{
    reward p,cur;
    queue<reward>qu;
    int ccount = 0;
    int ans = 0;
    for(int i = 1; i <= n; i++)
    {
        if(num[i]==0)       ///入度为0的点入队
        {
            p.index = i;
            p.money = 888;
            ans += p.money;
            qu.push(p);
            ccount++;       ///统计入队的点数
        }
    }
    if(ccount == n) return ans;
    while(!qu.empty())
    {
        cur = qu.front();
        qu.pop();
        for(int i = 0; i < node[cur.index].size(); i++)
        {
            int t = node[cur.index][i];
            p.index = t;
            p.money = cur.money+1;
            num[t]--;  
            if(num[t]==0)  
            {
                ans += p.money;
                qu.push(p);
                ccount++;
                if(ccount == n)
                    return ans;
            }
        }
    }
    return -1;
}
int main()
{
    while(~scanf("%d%d",&n,&m)) ///n个工人,m个要求
    {
        int a,b;
        for(int i = 1; i <= n; i++)
        {
            node[i].clear();        ///清空容器
            num[i] = 0;             ///节点i的入度初始化为0
        }
        for(int i = 0; i < m; i++)  
        {
            scanf("%d%d",&a,&b);    ///a的奖金必须大于b的奖金。方向为b->a
            node[b].push_back(a);
            num[a]++;               ///入度加1,
        }
        int temp = HaveTopSort();
        printf("%d\n",temp);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值