acm每日一练之一种排序

描述
现在有很多长方形,每一个长方形都有一个编号,这个编号可以重复;还知道这个长方形的宽和长,编号、长、宽都是整数;现在要求按照一下方式排序(默认排序规则都是从小到大);

1.按照编号从小到大排序

2.对于编号相等的长方形,按照长方形的长排序;

3.如果编号和长都相同,按照长方形的宽排序;

4.如果编号、长、宽都相同,就只保留一个长方形用于排序,删除多余的长方形;最后排好序按照指定格式显示所有的长方形;
输入
第一行有一个整数 0<n<10000,表示接下来有n组测试数据;
每一组第一行有一个整数 0<m<1000,表示有m个长方形;
接下来的m行,每一行有三个数 ,第一个数表示长方形的编号,

第二个和第三个数值大的表示长,数值小的表示宽,相等
说明这是一个正方形(数据约定长宽与编号都小于10000);
输出
顺序输出每组数据的所有符合条件的长方形的 编号 长 宽
样例输入
1
8
1 1 1
1 1 1
1 1 2
1 2 1
1 2 2
2 1 1
2 1 2
2 2 1
样例输出
1 1 1
1 2 1
1 2 2
2 1 1
2 2 1

code

public class Main {

    public static void main(String[] args) throws NumberFormatException, IOException {
        
        class Rec implements Comparable<Rec> {
            int num;

            int length;

            int width;

            public void setNum(int num) {
                this.num = num;
            }

            public void setLength(int length) {
                this.length = length;
            }

            public void setWidth(int width) {
                this.width = width;
            }

            @Override
            public int hashCode() {
                final int prime = 31;
                int result = 1;
                result = prime * result + length;
                result = prime * result + num;
                result = prime * result + width;
                return result;
            }

            @Override
            public boolean equals(Object obj) {
                if (this == obj)
                    return true;
                if (obj == null)
                    return false;
                if (getClass() != obj.getClass())
                    return false;
                Rec other = (Rec) obj;
                if (length != other.length)
                    return false;
                if (num != other.num)
                    return false;
                if (width != other.width)
                    return false;
                return true;
            }

            @Override
            public String toString() {
                return num + " " + length + " " + width;
            }

            @Override
            public int compareTo(Rec o) {
                int cmpNum = num - o.num;
                int cmpLen = length - o.length;
                int cmpWid = width - o.width;
                return cmpNum == 0 ? (cmpLen == 0 ? cmpWid : cmpLen) : cmpNum;
            }
        }
        
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        ArrayList<HashSet<Rec>> strs = new ArrayList<HashSet<Rec>>();
        while (n-- > 0) {
            int size = sc.nextInt();
            HashSet<Rec> group = new HashSet<Rec>();
            while (size-- > 0) {
                Rec rec = new Rec();
                int i = 3;
                while (i-- > 0) {
                    int temp = sc.nextInt();
                    if (i == 2)
                        rec.setNum(temp);
                    if (i == 1)
                        rec.setLength(temp);
                    if (i == 0) {
                        int length = rec.length;
                        rec.setWidth(temp < length ? temp : length);
                        rec.setLength(temp > length ? temp : length);
                    }
                }
                group.add(rec);
            }
            strs.add(group);
        }
        for (HashSet<Rec> group : strs) {
            ArrayList<Rec> recs = new ArrayList<Rec>(group);
            Collections.sort(recs);
            for (Rec line : recs) {
                System.out.println(line);
            }
        }
    }
}

没什么好说的,就一个简单的排序。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值